Bug 782736 - form text field with text type "multi-line with formatting" is printed enlarged
form text field with text type "multi-line with formatting" is printed enlarged
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 05:20 EST by Kyrre Ness Sjøbæk
Modified: 2012-12-20 10:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ODT form provoking the bug (80.07 KB, application/vnd.oasis.opendocument.text)
2012-01-18 05:20 EST, Kyrre Ness Sjøbæk
no flags Details
if I export as pdf its ok (172.76 KB, application/pdf)
2012-03-27 08:11 EDT, Caolan McNamara
no flags Details
but use print to file and mangled oddly (135.01 KB, application/pdf)
2012-03-27 08:12 EDT, Caolan McNamara
no flags Details
minimal reproducer (9.15 KB, application/vnd.oasis.opendocument.text)
2012-12-20 08:24 EST, David Tardon
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2012-01-18 05:20:24 EST
Created attachment 555979 [details]
ODT form provoking the bug

Description of problem:
When filling out and printing the attached ODT form, some text fields are grossly enlarged. Further, the color scheme from the computer is also used when generating the output, which may result in a huge black box covering much of the sheet (this was seen on a colleagues Ubuntu machine)

Version-Release number of selected component (if applicable):
libreoffice-writer-3.4.4.2-7.fc16.x86_64

How reproducible:


Steps to Reproduce:
1. Open linked document
2. Type in something in the form (I tried just the last table on page 1)
3. Print
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2012-03-27 08:11:09 EDT
Created attachment 573039 [details]
if I export as pdf its ok
Comment 2 Caolan McNamara 2012-03-27 08:12:20 EDT
Created attachment 573040 [details]
but use print to file and mangled oddly
Comment 3 David Tardon 2012-12-20 08:23:36 EST
The problem is related to property "text type" = "multi-line with formatting" of the text fields. Changing this to "single-line" or "multi-line" makes it print correctly.
Comment 4 David Tardon 2012-12-20 08:24:20 EST
Created attachment 666655 [details]
minimal reproducer
Comment 5 David Tardon 2012-12-20 10:42:15 EST
Since this problem only arises in quite specific circumstances, I am not going to backport the fix into Fedora.

Note You need to log in before you can comment on or make changes to this bug.