Bug 782780 - [eap6] Domain management port is wrongly detected
[eap6] Domain management port is wrongly detected
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
3.0.1
Unspecified Linux
high Severity urgent (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-01-18 07:40 EST by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:18:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2012-01-18 07:40:54 EST
Description of problem:

Port where DomainController is listening is not detected properly, my host.xml (unsecured) contains:


<management-interfaces>
 <native-interface  >
  <socket interface="management" port="8999"/>
 </native-interface>
 <http-interface  >
  <socket interface="management" port="8990"/>
 </http-interface>
</management-interfaces>

and RHQ detects port as 9990. I have already running EAP6 in standalone mode listening on 9990.

Version-Release number of selected component (if applicable):
Version: 4.3.0-SNAPSHOT
Build Number: 81533f2
EAP6 DR9

How reproducible:always


Steps to Reproduce:
1.Start EAP6 in standalone mode (unsecure http and native interfaces)
2.Start EAP6 in domain mode / another copy of EAP, same host with above content of host.xml
3.Inventory both by agent
  
Actual results: BZs bellow are still reproducible

Additional info: It seems to be a root cause of following:
https://bugzilla.redhat.com/show_bug.cgi?id=766284
https://bugzilla.redhat.com/show_bug.cgi?id=769913
Comment 2 Mike Foley 2012-02-07 14:18:22 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.