Bug 782796 - Adding event log source leads to unavailable resource
Adding event log source leads to unavailable resource
Status: CLOSED DUPLICATE of bug 773435
Product: RHQ Project
Classification: Other
Component: Events (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon30-sprint10/rhq43-sprint10
  Show dependency treegraph
 
Reported: 2012-01-18 09:17 EST by bkramer
Modified: 2012-01-25 19:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-18 12:29:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2012-01-18 09:17:53 EST
Description of problem:
Adding event log source to a resource (running on the platform that does not have native supported) will lead to unavailable resource 

Version-Release number of selected component (if applicable):
JON 3.0 GA 

How reproducible:
Always

Steps to Reproduce:
1. Run JON Server and JON Agent with --nonative option
2. Manually add JBoss EAP server and check that it's green/available 
3. For newly added JBoss EAP server, in Inventory -> Connection Settings, add and enable <JBOSS_HOME>/server/<profile>/log/server.log file and save the change
4. From the Agent command line execute "avail" command
  
Actual results:
JBoss EAP server that initially was green, became red and unavailable after this change. 

Expected results:
JBoss EAP server should stay available.

Additional info:
The following exception is logged:

2012-01-18 13:45:52,298 INFO  [ResourceContainer.invoker.daemon-7] (org.rhq.plugins.jbossas5.ApplicationServerComponent)- Successfully obtained a JMX connection to jnp://10.33.1.120:1099
2012-01-18 13:45:52,327 DEBUG [InventoryManager.availability-1] (rhq.core.pc.inventory.ResourceContainer$ResourceComponentInvocationHandler)- Call to [org.rhq.plugins.jbossas5.ApplicationServerComponent.start()] with args [[org.rhq.core.pluginapi.inventory.ResourceContext@6f132c25]] failed.
java.util.concurrent.ExecutionException: org.rhq.core.system.SystemInfoException: Native layer is not available or has been disabled
        at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:232)
        at java.util.concurrent.FutureTask.get(FutureTask.java:91)
        at org.rhq.core.pc.inventory.ResourceContainer$ResourceComponentInvocationHandler.invokeInNewThreadWithLock(ResourceContainer.java:473)
        at org.rhq.core.pc.inventory.ResourceContainer$ResourceComponentInvocationHandler.invoke(ResourceContainer.java:461)
        at $Proxy41.start(Unknown Source)
        at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:1588)
        at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:202)
        at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:238)
        at org.rhq.core.pc.inventory.AvailabilityExecutor.call(AvailabilityExecutor.java:127)
        at org.rhq.core.pc.inventory.AvailabilityExecutor.run(AvailabilityExecutor.java:90)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
Caused by: org.rhq.core.system.SystemInfoException: Native layer is not available or has been disabled
        at org.rhq.core.system.SigarAccess.getSigar(SigarAccess.java:61)
        at org.rhq.core.pc.event.EventManager.getSigar(EventManager.java:118)
        at org.rhq.core.pc.event.EventContextImpl.getSigar(EventContextImpl.java:104)
        at org.rhq.core.pluginapi.event.log.LogFileEventPoller.<init>(LogFileEventPoller.java:60)
        at org.rhq.core.pluginapi.event.log.LogFileEventResourceComponentHelper.startLogFileEventPollers(LogFileEventResourceComponentHelper.java:113)
        at org.rhq.plugins.jbossas5.ApplicationServerComponent.start(ApplicationServerComponent.java:185)
        at sun.reflect.GeneratedMethodAccessor30.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:552)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        ... 3 more
Comment 1 Jay Shaughnessy 2012-01-18 12:29:16 EST
There were recently a few fixes (in master) in this area.  This looks like
a duplicate of either 773435 and may also be related to 772771 or 773031.

*** This bug has been marked as a duplicate of bug 773435 ***

Note You need to log in before you can comment on or make changes to this bug.