Bug 783108 - spamassassin.service lies about its PID file
spamassassin.service lies about its PID file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-19 06:34 EST by Michal Schmidt
Modified: 2012-01-30 16:02 EST (History)
5 users (show)

See Also:
Fixed In Version: spamassassin-3.3.2-9.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-30 16:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-01-19 06:34:19 EST
Description of problem:

/lib/systemd/system/spamasssassin.service says:
PIDFile=/var/run/spamd.pid

but spamd never writes this pid file.
It is crucial that *.service files contain true information about the PIDFile,
otherwise the service will misbehave.
The service will fail to start under latest versions of systemd, because systemd will not treat the service as started successfully unless the configured pid file appears.

Version-Release number of selected component (if applicable):
spamassassin-3.3.2-7.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. update to systemd-37-8.fc16 from updates-testing
2. attempt to restart spamassasin.service
  
Actual results:
The service will be "activating" for a minute or two and then it will timeout and be killed.

Expected results:
The service state should become "active (running)" in a few seconds.

Additional info:

Suggested fix in the unit file: add --pidfile to spamd command line:

ExecStart=/usr/bin/spamd --pidfile /var/run/spamd.pid $SPAMDOPTIONS
Comment 1 Jan ONDREJ 2012-01-19 14:48:07 EST
Please, fix this before this update:

https://admin.fedoraproject.org/updates/FEDORA-2012-0409/systemd-37-8.fc16

will go to stable.
Comment 2 Fedora Update System 2012-01-19 15:44:51 EST
spamassassin-3.3.2-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spamassassin-3.3.2-9.fc16
Comment 3 Fedora Update System 2012-01-21 16:54:17 EST
Package spamassassin-3.3.2-9.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spamassassin-3.3.2-9.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0754/spamassassin-3.3.2-9.fc16
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-01-30 16:02:48 EST
spamassassin-3.3.2-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.