Bug 78311 - In Turkish locale text on gedit menus and dialogs can not be read
In Turkish locale text on gedit menus and dialogs can not be read
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gedit (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-20 21:37 EST by onur Yalaz}
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 20:49:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Showing the strange labels (71.88 KB, image/jpeg)
2002-11-20 21:43 EST, onur Yalaz}
no flags Details
the tr.po file which reside on gtp website and gedit2.0.2 src it is not Turkish it's Tamil (72.14 KB, text/plain)
2002-11-20 22:02 EST, onur Yalaz}
no flags Details

  None (edit)
Description onur Yalaz} 2002-11-20 21:37:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
gedit 2.0.0 in tr_TR.utf8  locale 
can not be used because menu labels as well as preferences box labels shows
strange charecters instead of usable text

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.nothing just open gedit 2.0.2
2.
3.
	

Actual Results:  The app is unusable.

Expected Results:  Menus should use some understandable text

Additional info:

I ve downloaded and compiled i386.src rpm of gedit 2.0.2 
but this strange bug still exists.

But if started with 

         env LANG=en_US gedit %U or 
         env LANG=en_US.utf8 gedit %U 

the labels are ok.
Comment 1 onur Yalaz} 2002-11-20 21:43:18 EST
Created attachment 85804 [details]
Showing the strange labels
Comment 2 Havoc Pennington 2002-11-20 21:54:47 EST
The problem is perhaps a lack of Turkish fonts. 
Is this problem specific to gedit or does it happen with all text
on the system? If some applications display Turkish correctly, 
which applications are they?
Comment 3 Havoc Pennington 2002-11-20 21:55:44 EST
From the screen shots it also looks possible that the turkish translations 
are simply in the wrong encoding.
Comment 4 onur Yalaz} 2002-11-20 21:59:38 EST
well i have just found out that the po file that's on gnome2.0 gtp site is in
TAMIL languge instead of Turkish. also this file is included with gedit2.0.2-5
src rpm
I ve just posted a bug report to gtp also.
Comment 5 onur Yalaz} 2002-11-20 22:02:15 EST
Created attachment 85805 [details]
the tr.po file which reside on gtp website and gedit2.0.2 src it is not Turkish it's Tamil
Comment 6 Havoc Pennington 2002-12-19 20:49:08 EST
I'm assuming this should be fixed in our newer gedit packages in rawhide.
If not, get the fix into GNOME upstream translation project, and 
we'll get the newer gedit packages with the fix.

Note You need to log in before you can comment on or make changes to this bug.