Bug 783143 - gnu time reports incorrect RAM usage
Summary: gnu time reports incorrect RAM usage
Keywords:
Status: CLOSED DUPLICATE of bug 703865
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: time
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-19 14:13 UTC by Philippe Naudin
Modified: 2012-02-08 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-08 09:18:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
test case (257 bytes, text/plain)
2012-02-08 09:10 UTC, Petr Pisar
no flags Details

Description Philippe Naudin 2012-01-19 14:13:07 UTC
Description of problem:
GNU time reports 4 times too much "maxresident" memory usage.

The problem and the fix are described here : 
http://www.mail-archive.com/help-gnu-utils@gnu.org/msg01371.html

Version-Release number of selected component (if applicable):
All versions at least up to 6.2

How reproducible:
Always 

Steps to Reproduce:
1. /usr/bin/time nano <some.file> # or any other command
2. from an other terminal, check the memory used by the command (with ps, htop,...)
3. end nano (or the other command) and compare the "maxresident" reported by time with what was found by the other tools.
  
Actual results:


Expected results:


Additional info:

Comment 2 Petr Pisar 2012-02-08 09:10:19 UTC
Created attachment 560194 [details]
test case

Comment 3 Petr Pisar 2012-02-08 09:18:17 UTC

*** This bug has been marked as a duplicate of bug 703865 ***


Note You need to log in before you can comment on or make changes to this bug.