Bug 78324 - nautius monitors the floppy when it doesn't need to
nautius monitors the floppy when it doesn't need to
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
: 80550 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-21 09:00 EST by Bill Bledsoe
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 08:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Bledsoe 2002-11-21 09:00:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
fam is started automatically on 3 of my RH 8.0 computers. As long as it is
running, I can mount a floppy with "mount /dev/fd0 /mnt/floppy" or with  the RH
GUI Disk manager. But when I go to umount it or use the GUI to umount it, it
reports that it is busy. It does not matter what directories the terminal
command line is pointing to. It does not matter what directories the File
Manager is pointing to. It does not even matter if either the File Manager or
the Terminal is on or off. The "fam" process locks up the /mnt/floppy and it
stays busy until the fam process is killed. The command "fuser -m -v -a
/mnt/floppy/" shows that fam is the only process using the floppy. When I kill
the fam process with "kill 1113", the floppy umounts fine and works perfectly as
long as fam is off.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Load all of RH 8.0
2.Mount a floppy.
3.The floppy will not umount.
	

Actual Results:  The floppy reports "this device is busy" and will not umount
with the GUI Disk Manager or from the command line.


Expected Results:  "umount /mnt/floppy" should work and so should unmounting the
floppy from the GUI Disk Manager.

Additional info:

This is found on the three RH 8.0 servers I have set up.If I do not stop the fam
process, the floppy can not be written to or information recovered from it. It
crashes the floppy and often requires a (gasp) total reboot to continue using RH
8.0 if the fam process is not killed.
Comment 1 Alexander Larsson 2002-11-22 04:40:01 EST
The question is what is causing fam to monitor that file. Fam never does
anything on itself, only by request from a client.
Do you run a desktop on the machine? Does nautilus or konqueror run?
Comment 2 Bill Bledsoe 2002-11-22 12:42:30 EST
I run the default RH 8.0 GNOME desktop. Nautilus runs automatically. Someone 
suggested nautilus as the culprit in our Linux users group. I tried to use the 
kill command to kill the nautilus and the system would automatically restart 
nautilus under a new PID. Nautilus File Browser does not have to be open for 
the floppy to lock up. I do not open the nautilus when I mount the floppy and 
it still locks up. If Nautilus opens, I do not change to the floppy directory 
at all. It stays at the default root directory and still locks up.
I do not know how to tell what calls the fam process. If there is a way, let me 
know and I will run the commands and give you feedback.
I hope this helps.
Comment 3 Alexander Larsson 2002-11-25 09:46:05 EST
Try running "killall -9 nautilus" lots of times repeatedly until nautilus no
longer comes up again, and see if fam still monitors the floppy.
Comment 4 Bill Bledsoe 2002-11-25 17:44:20 EST
Yes the "killall -9 nautilus" command after fam has the floppy locked will 
release the fam and allow the floppy to umount normally.
Comment 5 Alexander Larsson 2002-11-26 03:52:27 EST
So. Now to figure out why nautilus was monitoring that directory.
Did you ever view the floppy in nautilus?
Did you ever move something on the floppy to the trash?
Comment 6 Bill Bledsoe 2002-11-26 09:01:54 EST
<Did you ever view the floppy in nautilus?> 
Answer: No. It locks up even if nautilus is not open. I do not have to view the 
floppy in nautilus. It locks up with only the "terminal command line window" 
opened and running. It locks up with only the RH disk manager mounting and 
umounting the floppy.
Interesting enough, once nautilus is killed, both the terminal window and RH 
disk manager work to mount and umount the floppy. They continue to work until I 
open the nautilus to the root directory only and then close nautilus. From then 
on they fail until I use the "kill -9 nautilus" command again. 


<Did you ever move something on the floppy to the trash?> 
Answer: No. I have not deleted from the floppy.

Comment 7 Alexander Larsson 2002-11-26 12:00:10 EST
Do you get a floppy icon on the desktop?
Comment 8 Bill Bledsoe 2002-11-26 15:41:36 EST
<Do you get a floppy icon on the desktop?>
Answer: Yes the icon is on the desktop. I never paid attention to it. If I 
right click the icon and select "Eject" the floppy umounts. The "umount 
command" does not work from the "RH disk manager" or from the "terminal command 
line" but the "floppy icon's Eject button" will umount the floppy normally. I 
guess this means that the icon is the culprit and will not release the floppy 
without selecting the "EJECT" button.
Comment 9 Alexander Larsson 2002-11-27 04:28:32 EST
It means that nautilus is monitoring something on the floppy, and when Nautilus
is asked to unmount the floppy it knows it has to stop monitoring it first. That
doesn't happen when you try to unmount from the command line.

I don't understand why it was monitoring the floppy if you've never looked at it
with nautilus though.
Comment 10 Alexander Larsson 2003-10-22 06:24:23 EDT
*** Bug 80550 has been marked as a duplicate of this bug. ***
Comment 11 Jeff Kowing 2003-10-30 16:43:45 EST
I'm having what I believe to be the same problem, except with a USB memory key.
I have added my report to a bug already in the gnome nautilus bugzilla that may
be of interest.  In fact, the behavior seems to be the same, whether for the USB
memory key or for a floppy.

http://bugzilla.gnome.org/show_bug.cgi?id=115211
Comment 12 Alexander Larsson 2004-10-04 08:53:22 EDT
I believe this is fixed in fc3 with gnome 2.8 and gamin. Reopen if you
see this again.

Note You need to log in before you can comment on or make changes to this bug.