Bug 783334 - gcc-4.7.0-0.6.fc17 ICEs building numpy on armv7hl
Summary: gcc-4.7.0-0.6.fc17 ICEs building numpy on armv7hl
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-20 02:20 UTC by Brendan Conoboy
Modified: 2012-01-24 07:38 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-01-24 07:38:13 UTC


Attachments (Terms of Use)
Preprocessed source of scalartypes.c, bzip2 compressed (262.86 KB, application/x-bzip2)
2012-01-20 02:20 UTC, Brendan Conoboy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 51915 None None None Never

Description Brendan Conoboy 2012-01-20 02:20:47 UTC
Created attachment 556442 [details]
Preprocessed source of scalartypes.c, bzip2 compressed

Description of problem:

Building numpy-1.6.1-1.fc17.src.rpm with gcc-4.7.0-0.6.fc17.armv7hl fails due to an ICE.  The same numpy sources succeed when built with gcc-4.6.1-9.fc15.0.arm5.armv7hl (This gcc version contains a small expr.c patch now in 4.6 branch but is otherwise based on the F15 source).


Version-Release number of selected component (if applicable):
numpy-1.6.1-1.fc17.src.rpm
gcc-4.7.0-0.6.fc17.armv7hl

How reproducible:
Every time.

Steps to Reproduce:
1.rpmbuild --rebuild numpy-1.6.1-1.fc17.src.rpm
(The gcc command line is hidden by the build system)

Actual results:
In file included from numpy/core/src/multiarray/multiarraymodule_onefile.c:10:0:
numpy/core/src/multiarray/scalartypes.c.src: In function 'ulonglong_index':
numpy/core/src/multiarray/scalartypes.c.src:2340:1: internal compiler error: in output_move_double, at config/arm/arm.c:13958
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
{standard input}: Assembler messages:
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
Preprocessed source stored into /tmp/ccEoiCeM.out file, please attach this to your bugreport.

Expected results:
Smooth compilation.

Additional info:
See the attached preprocessed source.

Comment 1 Brendan Conoboy 2012-01-20 02:22:22 UTC
Setting to gcc since it's not likely numpy's fault.


Note You need to log in before you can comment on or make changes to this bug.