Bug 783556 - [abrt] libreoffice-core-3.4.4.2-7.fc16: ScMatrix::GetDimensions: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.4.4.2-7.fc16: ScMatrix::GetDimensions: Process /usr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
abrt_hash:ac4a8d22d3384c24aaab65261f3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-20 15:10 EST by Itamar Reis Peixoto
Modified: 2012-02-16 19:57 EST (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-16 19:57:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (19.25 KB, text/plain)
2012-01-20 15:10 EST, Itamar Reis Peixoto
no flags Details
File: maps (75.94 KB, text/plain)
2012-01-20 15:11 EST, Itamar Reis Peixoto
no flags Details
File: backtrace (93.84 KB, text/plain)
2012-01-20 15:11 EST, Itamar Reis Peixoto
no flags Details

  None (edit)
Description Itamar Reis Peixoto 2012-01-20 15:10:50 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///tmp/Database+function-2.xlsx --splash-pipe=7
crash_function: ScMatrix::GetDimensions
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.1.9-1.fc16.x86_64
pid:            23769
pwd:            /home/itamar
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Fri 20 Jan 2012 04:36:59 PM BRST
uid:            1000
username:       itamar
xsession_errors: 

backtrace:      Text file, 96094 bytes
dso_list:       Text file, 19716 bytes
maps:           Text file, 77761 bytes

environ:
:XDG_VTNR=1
:XSUNTRANSPORT=shmem
:ORBIT_SOCKETDIR=/tmp/orbit-itamar
:XDG_SESSION_ID=2
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=23756
:GPG_AGENT_INFO=/tmp/keyring-e2mBY4/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=06f3e522c81780e302c6e83a0000000b-1326823524.893780-723524581
:XRE_PROFILE_NAME=
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-e2mBY4
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:XRE_IMPORT_PROFILES=
:MOZILLA_FIVE_HOME=/usr/lib64/firefox
:IMSETTINGS_MODULE=none
:USER=itamar
:XRE_PROFILE_LOCAL_PATH=
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64:/usr/lib64/firefox:/usr/lib64/firefox/plugins:/usr/lib64/firefox
:XRE_START_OFFLINE=
:SSH_AUTH_SOCK=/tmp/keyring-e2mBY4/ssh
:LIBPATH=/usr/lib64/firefox:/usr/lib64/firefox
:USERNAME=itamar
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1530,unix/unix:/tmp/.ICE-unix/1530
:GNOME_DISABLE_CRASH_DIALOG=1
:PLPLOT_LIB=/usr/share/EMBOSS
:MOZ_APP_LAUNCHER=/usr/bin/firefox
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-calc.desktop
:MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins-wrapped:/usr/lib64/firefox/plugins-wrapped
:MAIL=/var/spool/mail/itamar
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/itamar/.local/bin:/home/itamar/bin
:DESKTOP_SESSION=gnome
:FONTCONFIG_PATH=/etc/fonts:/usr/lib64/firefox/res/Xft
:QT_IM_MODULE=xim
:PWD=/home/itamar
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=1526
:LANG=en_US.UTF-8
:XRE_PROFILE_PATH=
:KDEDIRS=/usr
:XSUNSMESIZE=512
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:EMBOSS_ACDROOT=/usr/share/EMBOSS/acd
:HOME=/home/itamar
:XDG_SEAT=seat0
:SHLVL=1
:EMBOSS_DATA=/usr/share/EMBOSS/data
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:DYLD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:LOGNAME=itamar
:MOZ_GRE_CONF=/etc/gre.d/gre64.conf
:MOZ_LAUNCHED_CHILD=
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-CV3AUAqfRL,guid=9c49682fd7283109df934aad00000135
:EMBOSS_DOCROOT=/usr/share/EMBOSS/doc
:NO_EM_RESTART=
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:EMBOSS_DATABASE_DIR=/usr/share/EMBOSS/data
:SHLIB_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:MOZ_CRASHREPORTER_RESTART_ARG_1=
:WINDOWPATH=1
:MOZ_CRASHREPORTER_RESTART_ARG_0=/usr/lib64/firefox/firefox
:XRE_BINARY_PATH=
:XDG_RUNTIME_DIR=/run/user/itamar
:DISPLAY=:0
:'MOZ_CRASHREPORTER_DATA_DIRECTORY=/home/itamar/.mozilla/firefox/Crash Reports'
:XUL_APP_FILE=
:NO_AT_BRIDGE=1
:XAUTHORITY=/var/run/gdm/auth-for-itamar-RsO0v2/database

smolt_data:
:
:
:General
:=================================
:UUID: 2f4d8588-d70f-4322-8d8e-eacb95312c8f
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6384.76
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU         650  @ 3.20GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 3333
:System Memory: 3756
:System Swap: 5791
:Vendor: Hewlett-Packard
:System: HP Compaq 8100 Elite SFF Brazil PC 
:Form factor: Low Profile Desktop
:Kernel: 3.1.9-1.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11361:4156:12362) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:66:4156:12362) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15138:4156:12362) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15170:4156:12362) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15114:4156:12362) pci, None, PCI/ISA, 5 Series Chipset LPC Interface Controller
:(32902:15182:4156:12362) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 7
:(32902:11539:4156:12362) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15178:4156:12362) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:4156:12362) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:4335:4156:12362) pci, e1000e, ETHERNET, 82578DM Gigabit Network Connection
:(32902:15164:4156:12362) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:11537:4156:12362) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:9294:4156:12362) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:11538:4156:12362) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11536:4156:12362) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:15207:4156:12362) pci, serial, 16550_SERIAL, 5 Series/3400 Series Chipset KT Controller
:(32902:15156:4156:12362) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:64:4156:12362) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:15204:4156:12362) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:11521:4156:12362) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 12901535 6878864 6747792 3276800 2991753 2991753
:/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 25803080 17319544 16008825 6553600 6532347 6532347
:/dev/mapper/VolGroup-mirror WITHHELD ext4 4096 4096 28383400 2534576 1092816 7208960 7087606 7087606
:/dev/sda2 /boot ext4 1024 1024 495844 394891 369291 128016 127742 127742
:

var_log_messages:
:Jan 20 16:23:39 localhost kernel: [259970.724678] soffice.bin[21510]: segfault at 0 ip 00007f5b1772fb10 sp 00007fffc58f9878 error 4 in libsclx.so[7f5b172ec000+a66000]
:Jan 20 16:23:41 localhost abrt[21522]: Saved core dump of pid 21510 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-20-16:23:39-21510 (320385024 bytes)
:Jan 20 16:25:52 localhost kernel: [260104.221759] soffice.bin[21853]: segfault at 0 ip 00007f89af72fb10 sp 00007fff5b540a08 error 4 in libsclx.so[7f89af2ec000+a66000]
:Jan 20 16:25:55 localhost abrt[21864]: Saved core dump of pid 21853 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-20-16:25:52-21853 (320376832 bytes)
:Jan 20 16:36:59 localhost kernel: [260769.293136] soffice.bin[23769]: segfault at 0 ip 00007fe9861bbb10 sp 00007fffa8e0cb48 error 4 in libsclx.so[7fe985d78000+a66000]
:Jan 20 16:37:01 localhost abrt[23781]: Saved core dump of pid 23769 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-20-16:36:59-23769 (320462848 bytes)
Comment 1 Itamar Reis Peixoto 2012-01-20 15:10:56 EST
Created attachment 556591 [details]
File: dso_list
Comment 2 Itamar Reis Peixoto 2012-01-20 15:11:01 EST
Created attachment 556592 [details]
File: maps
Comment 3 Itamar Reis Peixoto 2012-01-20 15:11:03 EST
Created attachment 556593 [details]
File: backtrace
Comment 4 Eike Rathke 2012-01-20 15:41:09 EST
@itamar: do you have a test case scenario (spreadsheet document causing the crash) for this? I found the cause and can fix, but would like to verify the fix.
Comment 5 Eike Rathke 2012-01-23 10:04:22 EST
Resolved upstream in master http://cgit.freedesktop.org/libreoffice/core/commit/?id=a7769e27849b74102e11540d7753576528323114

Requested review for 3-5 and 3-4.
Comment 7 Fedora Update System 2012-02-07 11:43:52 EST
libreoffice-3.4.5.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.5.2-2.fc16
Comment 8 Fedora Update System 2012-02-07 21:27:43 EST
Package libreoffice-3.4.5.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.5.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1439/libreoffice-3.4.5.2-2.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-02-09 06:38:32 EST
libreoffice-3.4.5.2-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.5.2-5.fc16
Comment 10 Fedora Update System 2012-02-16 19:57:10 EST
libreoffice-3.4.5.2-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.