Bug 783586 - Build failure - internal compiler error: in tsubst, at cp/pt.c:11285
Build failure - internal compiler error: in tsubst, at cp/pt.c:11285
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 783463 784272 (view as bug list)
Depends On:
Blocks: kde-4.8
  Show dependency treegraph
 
Reported: 2012-01-20 17:36 EST by Matthias Clasen
Modified: 2012-01-24 08:14 EST (History)
4 users (show)

See Also:
Fixed In Version: gcc-4.7.0-0.9.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-24 02:38:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source file (1.88 MB, application/octet-stream)
2012-01-20 17:36 EST, Matthias Clasen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 51925 None None None Never

  None (edit)
Description Matthias Clasen 2012-01-20 17:36:04 EST
Created attachment 556618 [details]
preprocessed source file

Building PackageKit-0.7.2 with gcc 4.7 in todays rawhide ends with:

/usr/include/QtDBus/qdbuspendingreply.h: In substitution of 'template<class T1, class T2, class T3, class T4, class T5, class T6, class T7, class T8> template<int Index> const typename QDBusPendingReply<T1, T2, T3, T4, T5, T6, T7, T8>::Select::Type QDBusPendingReply::argumentAt() const [with int Index = <missing>; T1 = 0; T2 = <missing>; T3 = <missing>; T4 = <missing>; T5 = <missing>; T6 = <missing>; T7 = <missing>; T8 = <missing>]':
/usr/include/QtDBus/qdbuspendingreply.h:186:30:   required from 'QDBusPendingReply<T1, T2, T3, T4, T5, T6, T7, T8>::operator typename QDBusPendingReply<T1, T2, T3, T4, T5, T6, T7, T8>::Select<0>::Type() const [with T1 = QString; T2 = void; T3 = void; T4 = void; T5 = void; T6 = void; T7 = void; T8 = void; typename QDBusPendingReply<T1, T2, T3, T4, T5, T6, T7, T8>::Select<0>::Type = QString]'
daemon.cpp:153:68:   required from here
/usr/include/QtDBus/qdbuspendingreply.h:170:40: internal compiler error: in tsubst, at cp/pt.c:11285


I've attached the preprocessed source
Comment 1 Jakub Jelinek 2012-01-20 19:02:07 EST
*** Bug 783463 has been marked as a duplicate of this bug. ***
Comment 2 Kevin Kofler 2012-01-23 11:03:19 EST
Ping? This is breaking the build of almost all Qt-using packages…
Comment 3 Kevin Kofler 2012-01-23 11:55:42 EST
Upstream fix: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=51925#c2
Comment 4 Jakub Jelinek 2012-01-24 08:14:05 EST
*** Bug 784272 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.