Bug 783629 - httpd starts before named
Summary: httpd starts before named
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 16
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Kaluža
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-21 07:43 UTC by Frank Crawford
Modified: 2012-04-01 22:56 UTC (History)
4 users (show)

Fixed In Version: httpd-2.2.22-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-01 22:56:36 UTC
Type: ---


Attachments (Terms of Use)

Description Frank Crawford 2012-01-21 07:43:05 UTC
Description of problem:
httpd start before named and fails if there are any DNS entries requiring resolution.

Version-Release number of selected component (if applicable):
httpd-2.2.21-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot the system
2. View /var/log/boot.log
3.
  
Actual results:
httpd starts before named and fails due to unresolved hostnames.

Expected results:
named starts first and all hostnames are resolved.

Additional info:
The SysV/LSB file includes a dependency on named, but systemd entry does not.

Comment 1 Jan Kaluža 2012-01-23 09:22:09 UTC
I'm not sure if it's possible to fix it currently, because bind doesn't have systemd unit file yet (see Bug 719419). I will try to find out if it's possible to start named (which still uses LSB init script) before httpd which uses systemd.

Comment 2 Frank Crawford 2012-01-23 10:33:34 UTC
Are you sure that you can't refer to SysV init scripts as well?  the systemd.service(5) man page says that if a service is requested it will dynamically create a service unit for the script.

Also, if all else fails there is a "SysVStartPriority" option for service units, which is a "temporary compatibility option".

Note that I haven't tried either of these options.

Comment 3 Jan Kaluža 2012-01-23 12:03:27 UTC
Right, I've found out it should be possible to just use this:

After: nss-lookup.target

And I've already committed it to rawhide.

Comment 4 Frank Crawford 2012-01-23 12:08:47 UTC
I'll try it out as soon as it is available.

Thanks.

Comment 5 Fedora Update System 2012-03-05 11:44:51 UTC
httpd-2.2.22-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/httpd-2.2.22-2.fc16

Comment 6 Fedora Update System 2012-03-06 19:25:42 UTC
Package httpd-2.2.22-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing httpd-2.2.22-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3001/httpd-2.2.22-2.fc16
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-04-01 22:56:36 UTC
httpd-2.2.22-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.