Bug 78366 - rpm freezes over
Summary: rpm freezes over
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-21 20:01 UTC by Florin Andrei
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-21 20:14:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florin Andrei 2002-11-21 20:01:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I tried to uninstall VMwareWorkstation-3.1.1 evaluation version. I run "rpm -ev
package-name", it obviously did a few things (i've heard the HDD making noises),
but then the rpm process was frozen: it didn't return the command-line prompt.
I waited for a reasonable time (a few minutes). Nothing. Still frozen. The
system was not busy at all.
I tried CTRL-C. No reaction.
I tried "killall rpm". Nothing.
I tried "kill pid". Nothing.
At last, i run "kill -9" on the pid and that killed it. However, now i'm worried
about the status of my RPM database. :-(

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

It is not the first time rpm freezes over with Red Hat 8.0
Obviously, something's very wrong with it. Please identify the bug.

Comment 1 Florin Andrei 2002-11-21 20:03:43 UTC
Ok, now i'm trying to "rpm -Uvh" another package, and rpm is blocked. It does
not install the package, it does not return an error. I have to kill -9 it.

Comment 2 Florin Andrei 2002-11-21 20:05:04 UTC
rpm --rebuilddb doesn't work either. Again, only kill -9 solves it.
Very bad. :-(

Comment 3 Florin Andrei 2002-11-21 20:14:04 UTC
Ok, i rebooted the system, and now i can run rpm again. I'm rebuilding the
database right now.
"Reboot to fix" doesn't seem like Linux...

Comment 4 Jeff Johnson 2002-11-21 20:56:30 UTC
I knew this was a plot to make me run WinDoze!

Yup, you need to do
	rm -f /var/lib/rpm/__db*
after doing "kill -9", that's what the reboot did for you.

Original problem was probably missed SIGCHLD, packages
with that fix currently at
	ftp://people.redhat.com/jbj/test-4.1

See bugzilla #73097 for details.


Note You need to log in before you can comment on or make changes to this bug.