This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 783677 - llvm 3.1 for april
llvm 3.1 for april
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-21 12:15 EST by MERCIER Jonathan
Modified: 2012-02-01 20:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-01 20:35:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description MERCIER Jonathan 2012-01-21 12:15:12 EST
Hi,
like LLVM 3.1 will be released around april. It will be great if fedora 17 repo can follow upstream periodiaclly to 3.1

Thanks
Comment 1 Michel Alexandre Salim 2012-02-01 20:35:58 EST
Can't do -- as we've discussed previously, because LLVM is used in critical parts (e.g. for Mesa -- in fact, GNOME Shell 3.4's ability to run without 3D acceleration depends on this), we can't ship an upgraded LLVM unless upstream starts doing pre-release testing before our feature freeze. Which they have not.

Right now, with GCC 4.7.0 in Rawhide, we can't even build either LLVM 3.0 or LLVM trunk. LLVM 3.1 is definitely not a good idea at this stage.

Once F17 is branched and Rawhide is free-for-all again, I'd consider this, but even then, from experience many of the packages that build against LLVM only support stable releases, so there'll be an outcry when the LLVM snapshot lands. I think I'll actually ask rel-eng for a special tag for rebuilding the LLVM stack against the 3.1 pre-releases, and only land them in Rawhide once the major parts are ready.

Note You need to log in before you can comment on or make changes to this bug.