Bug 783712 - No wireless Access points - Fedora-17-Nightly Composes and RC-3-Desktop live i686
No wireless Access points - Fedora-17-Nightly Composes and RC-3-Desktop live ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
AcceptedNTH
: Reopened
: 795007 (view as bug list)
Depends On:
Blocks: F17Alpha-accepted/F17AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-01-21 17:28 EST by satellitgo
Modified: 2013-02-04 16:09 EST (History)
9 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.3-0.2.git20120215.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 12:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log from wpa_supplicant (4.28 KB, text/x-log)
2012-01-26 17:13 EST, Kjartan Maraas
no flags Details

  None (edit)
Description satellitgo 2012-01-21 17:28:24 EST
Description of problem:
Unable to see Wireless AP and AD-Hoc network Points in todays f17 Sugar (rawhide) Nightly Compose-(This is First f17 one to boot)

Fedora-17-Nightly-20120120.10-i686-Live-soas.iso
booted as live CD

Version-Release number of selected component (if applicable):
Fedora-17-Nightly-20120120.10-i686-Live-soas.iso

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
No Wireless AP or AD-Hoc network Points in f1 Neighborhood view
Browsers and Jabber.sugarlabs.org work if cat-5 wired cable is connected.

Expected results:
Wireless AP or AD-Hoc network Points in f1 Neighborhood view


Additional info:
All previous SoaS versions have allowed my test Netbook to see these AP's
Comment 1 Kjartan Maraas 2012-01-23 05:06:19 EST
I also don't see any wireless networks here with rawhide. This is with the wl (broadcom) driver from rpmfusion-nonfree which has worked fine in earlier releases. I updated to the latest kernel from koji to get the driver to compile again today.
Comment 2 Kjartan Maraas 2012-01-23 06:51:09 EST
Relevant information for eth1 (wireless) from syslog:

Jan 23 12:40:51 e4300 NetworkManager[4019]: <info> (eth1): now unmanaged
Jan 23 12:40:51 e4300 NetworkManager[4019]: <info> (eth1): device state change: unavailable -> unmanaged (reason 'removed') [20 10 36]
Jan 23 12:40:51 e4300 NetworkManager[4019]: <info> (eth1): cleaning up...
Jan 23 12:40:51 e4300 NetworkManager[4019]: <info> (eth1): taking down device.
Jan 23 12:40:51 e4300 avahi-daemon[971]: Withdrawing address record for fe80::e60:76ff:fe47:cc08 on eth1.
Jan 23 12:40:51 e4300 NetworkManager[4019]: NetworkManager[4019]: <info> (eth1): now unmanaged
Jan 23 12:40:51 e4300 NetworkManager[4019]: NetworkManager[4019]: <info> (eth1): device state change: unavailable -> unmanaged (reason 'removed') [20 10 36]
Jan 23 12:40:51 e4300 NetworkManager[4019]: NetworkManager[4019]: <info> (eth1): cleaning up...
Jan 23 12:40:51 e4300 NetworkManager[4019]: NetworkManager[4019]: <info> (eth1): taking down device.
Jan 23 12:40:52 e4300 NetworkManager[4669]: <error> [1327318852.94348] [nm-device-wifi.c:3079] real_update_permanent_hw_address(): (eth1): unable to read permanent MAC address (error 0)
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): driver supports SSID scans (scan_capa 0x01).
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): new 802.11 WiFi device (driver: 'wl' ifindex: 3)
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): exported as /org/freedesktop/NetworkManager/Devices/1
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): now managed
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): bringing up device.
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): preparing device.
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): deactivating device (reason 'managed') [2]
Jan 23 12:40:52 e4300 NetworkManager[4669]: <error> [1327318852.110384] [nm-supplicant-interface.c:570] interface_add_cb(): (eth1): error adding interface: wpa_supplicant couldn't grab this interface.
Jan 23 12:40:52 e4300 NetworkManager[4669]: <info> (eth1): supplicant interface state: starting -> down
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <error> [1327318852.94348] [nm-device-wifi.c:3079] real_update_permanent_hw_address(): (eth1): unable to read permanent MAC address (error 0)
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): driver supports SSID scans (scan_capa 0x01).
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): new 802.11 WiFi device (driver: 'wl' ifindex: 3)
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): exported as /org/freedesktop/NetworkManager/Devices/1
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): now managed
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): bringing up device.
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): preparing device.
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): deactivating device (reason 'managed') [2]
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <error> [1327318852.110384] [nm-supplicant-interface.c:570] interface_add_cb(): (eth1): error adding interface: wpa_supplicant couldn't grab this interface.
Jan 23 12:40:52 e4300 NetworkManager[4669]: NetworkManager[4669]: <info> (eth1): supplicant interface state: starting -> down
Jan 23 12:40:53 e4300 ntpd[970]: Deleting interface #11 eth1, fe80::e60:76ff:fe47:cc08#123, interface stats: received=0, sent=0, dropped=0, active_time=713 secs
Jan 23 12:40:53 e4300 avahi-daemon[971]: Registering new address record for fe80::e60:76ff:fe47:cc08 on eth1.*.
Jan 23 12:40:55 e4300 ntpd[970]: Listen normally on 14 eth1 fe80::e60:76ff:fe47:cc08 UDP 123
Comment 3 Jirka Klimes 2012-01-26 07:42:46 EST
Are you able to see APs with commands like iw or iwlist?

# iwlist eth1 scan
# iw eth1 scan
$ nmcli dev
$ nmcli wifi

$ rpm -q NetworkManager
$ rpm -q wpa_supplicant

[1327318852.110384] [nm-supplicant-interface.c:570] interface_add_cb(): (eth1):
error adding interface: wpa_supplicant couldn't grab this interface.
There was an error adding the interface to wpa_supplicant. It would be great to see wpa_supplicant logs, best with debugging on:
http://live.gnome.org/NetworkManager/Debugging#wpa_supplicant07
Comment 4 Kjartan Maraas 2012-01-26 17:13:28 EST
Created attachment 557756 [details]
log from wpa_supplicant

Looks like it's missing a netlink module - nl80211
Comment 5 Kjartan Maraas 2012-01-26 17:15:29 EST
I see networks and everything with iwlist.

[kmaraas@e4300 ~]$ iw eth1 scan
nl80211 not found.

[kmaraas@e4300 ~]$ nmcli dev
DEVICE     TYPE              STATE        
eth0       802-3-ethernet    connected    
eth1       802-11-wireless   unavailable  

[kmaraas@e4300 ~]$ rpm -q NetworkManager
NetworkManager-0.9.2-4.fc17.i686
[kmaraas@e4300 ~]$ rpm -q wpa_supplicant
wpa_supplicant-1.0-0.1.fc17.i686
Comment 6 Kjartan Maraas 2012-01-28 06:34:22 EST
Could this be related?
https://bugs.launchpad.net/ubuntu/+source/iw/+bug/370046
Comment 7 Dan Williams 2012-02-02 16:16:37 EST
So the output is caused by the cfg80211/nl80211 kernel modules not being loaded, because wl.o doesn't use them, and thus they aren't loaded.  NM is sending "nl80211,wext" as the supplicant driver, which should fall back to WEXT if nl80211 isn't available.

However, it appears that supplicant drivers have two initialization hooks, one for global init (once per driver) and one for interface init (called every for every new interface).  The problem is that the supplicant appears to treat a failure in global init as a hard failure and thus fails adding the new interface.

A workaround for testing purposes is to 'modprobe nl80211'.
Comment 8 Kjartan Maraas 2012-02-03 01:25:27 EST
[kmaraas@e4300 ~]$ sudo modprobe nl80211
[sudo] password for kmaraas: 
FATAL: Module nl80211 not found.
[kmaraas@e4300 ~]$ 

Is this in some kernel-extra-modules package or something like that?
Comment 9 Kjartan Maraas 2012-02-03 01:39:50 EST
Or is it just not enabled in the kernel builds for now?
Comment 10 Kjartan Maraas 2012-02-03 01:41:34 EST
Sorry for the noise. Too many Dan's @redhat.com :-)
Comment 11 Dan Williams 2012-02-03 10:57:31 EST
I think I meant cfg80211  instead of nl80211.  But in any case, try this build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3759546

and let me know how it goes.
Comment 12 satellitgo 2012-02-03 11:54:57 EST
(In reply to comment #11)
> I think I meant cfg80211  instead of nl80211.  But in any case, try this build:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3759546
> 
> and let me know how it goes.

http://koji.fedoraproject.org/koji/buildinfo?buildID=297232

installed the 5-i686 rpms in f17 alpha netinstall of gnome3,3.4; xfce;  and sugar via gnome rpm installer. Rebooted. still no Wireless AP's (or Ad-Hoc AP's) in sugar 0.95.1. Gnome3 sees Wireless AP in dropdown but has no pop up for wep password. Network settings shows AP in dropdown but does not allow Configure button.
Comment 13 Kjartan Maraas 2012-02-03 13:07:23 EST
modprobe cfg80211 fixed it with the current rawhide version of NetworkManager at least. I'll test the build in #comment 12 later.
Comment 14 satellitgo 2012-02-17 14:06:18 EST
(In reply to comment #12)
> (In reply to comment #11)
> > I think I meant cfg80211  instead of nl80211.  But in any case, try this build:
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=3759546
> > 
> > and let me know how it goes.
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=297232
> 
> installed the 5-i686 rpms in f17 alpha netinstall of gnome3,3.4; xfce;  and
> sugar via gnome rpm installer. Rebooted. still no Wireless AP's (or Ad-Hoc
> AP's) in sugar 0.95.1. Gnome3 sees Wireless AP in dropdown but has no pop up
> for wep password. Network settings shows AP in dropdown but does not allow
> Configure button.

Wireless AP-test
    requested by adamw on #fedora-bugzappers 
    shows wireless [on]/wireless on
        Lists 3 wireless AP's 
    * Click on wireless AP [on] list: NO POP-UP for settings occurs
    * System Settings/Network: 
        Wireless [ON] /Wireless Disconnected 
        3 wireless AP's show in [Network Name] dropdown click on it it will not hold it in window [Configure] is greyed out 
Link:
http://wiki.sugarlabs.org/go/Community/Distributions/Fedora-SoaS#Fedora-17-Nightly-20120217.09-i686-Live-desktop
Comment 15 Tim Flink 2012-02-17 14:15:45 EST
I just tried the 2012-02-17 Desktop x86_64 nightly livecd and I'm seeing the same thing - I can see all of the APs but when I attempt to connect, nothing happens.

Proposing as NTH for F17 Alpha - wired network access still works as a workaround, so it doesn't qualify as a blocker.
Comment 16 satellitgo 2012-02-18 18:34:35 EST
This also occurs in Fedora-17-Nightly-20120218.10-i686-Live-kde.iso as a booted  Live Cd and when installed to an external USB Hard-disk.
Wireless AP's are seen but this error occurs when trying to activate the Wireless AP (WEP)
"No Session found for uid 1000 (No session found for uid 1000)"
Comment 17 satellitgo 2012-02-18 20:13:05 EST
(In reply to comment #16)
> This also occurs in Fedora-17-Nightly-20120218.10-i686-Live-kde.iso as a booted
>  Live Cd and when installed to an external USB Hard-disk.
> Wireless AP's are seen but this error occurs when trying to activate the
> Wireless AP (WEP)
> "No Session found for uid 1000 (No session found for uid 1000)"

After a full update of the KDE hard-disk install with Apper / reboot and then install of sugar in Apper:

I can connect to Wireless AP in Manage Connections of KDE.

Then switch to Sugar-emulator in KDE
There I can see the wireless AP's and Ad-Hoc networks on f1 Network Neighborhood of Sugar. Wireless AP is already connected on start of emulator.

Update seems to have fixed wireless problem?

?Is this only for KDE-sugar?
Comment 18 Jóhann B. Guðmundsson 2012-02-20 09:23:38 EST
I do believe this is 795007 which in turn is caused by consolekit removal I believe...
Comment 19 Fedora Update System 2012-02-20 12:33:26 EST
NetworkManager-0.9.3-0.2.git20120215.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-1909/NetworkManager-0.9.3-0.2.git20120215.fc17
Comment 20 Adam Williamson 2012-02-20 14:42:20 EST
*** Bug 795007 has been marked as a duplicate of this bug. ***
Comment 21 Adam Williamson 2012-02-20 18:20:04 EST
I think we've had enough votes on IRC recently to make this NTH, we should pull the fix for RC3.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Fedora Update System 2012-02-20 21:23:25 EST
NetworkManager-0.9.3-0.2.git20120215.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 satellitgo 2012-02-21 12:33:26 EST
Fedora-17-Alpha-RC3-i686-Live-Desktop.iso

Testing-Live CD
Note have wired connection also in these tests
Gnome 3.3.5
/*\ wireless ABRT warning: problem in network manager:
"gnome-0.9.3-0.2 git 2012020215.f17 detected"
Wireless WEP cuts in and out.

Install to HD
use whole disk [lvm]
Firstboot works OK allows [X] NTP selection
 Gnome 3.3.5
 Intel IGD
Add/Remove Programs:
 sugar-emulator
 Constructionist learning platform
Logout triggers a [890.44115] endless scroll.
Power off and reboot
Logs in properly via gdm to gnome and sugar.
55 Updates
logout/login
*sugar
Ad-Hoc AP's show in (f1) Network Neighborhood
NO Wireless AP's
*GNOME
Wireless WEP cuts in and out.
Comment 24 Adam Williamson 2012-02-21 12:42:33 EST
I think it may be a better idea to open a new bug than to re-open this one.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 satellitgo 2012-02-21 12:56:52 EST
(In reply to comment #24)
> I think it may be a better idea to open a new bug than to re-open this one.
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

 new bug 795880

Note You need to log in before you can comment on or make changes to this bug.