Bug 783777 - Kernel update removes spaces from default boot entry (and breaks default)
Kernel update removes spaces from default boot entry (and breaks default)
Status: CLOSED DUPLICATE of bug 742720
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-22 08:58 EST by Robert Scheck
Modified: 2012-03-21 05:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 05:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2012-01-22 08:58:00 EST
Description of problem:

# grub2-mkconfig -o /etc/grub2.cfg 
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.1.9-1.fc16.x86_64
Found initrd image: /boot/initramfs-3.1.9-1.fc16.x86_64.img
Found linux image: /boot/vmlinuz-3.1.8-2.fc16.x86_64
Found initrd image: /boot/initramfs-3.1.8-2.fc16.x86_64.img
Found linux image: /boot/vmlinuz-3.1.6-1.fc16.x86_64
Found initrd image: /boot/initramfs-3.1.6-1.fc16.x86_64.img
  No volume groups found
Found Windows 7 (loader) on /dev/sda1
done
#

# grep "set default" /etc/grub2.cfg 
set default="Windows 7 (loader) (on /dev/sda1)"
#

Perform a "yum update" which contains a new kernel

# grep "set default" /etc/grub2.cfg 
set default="Windows7(loader) (on /dev/sda1)"
#

# cat /etc/default/grub 
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Fedora"
#GRUB_DEFAULT=saved
GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda1)"
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=de_DE.UTF-8  KEYTABLE=de-latin1-nodeadkeys"
#

Why does updating kernel remove the spaces in the default? Even running
grub2-mkconfig(1) does not break it.

Version-Release number of selected component (if applicable):
grub2-1.99-13.fc16.x86_64
kernel-3.1.6-1.fc16.x86_64
kernel-3.1.8-2.fc16.x86_64
kernel-3.1.9-1.fc16.x86_64

How reproducible:
Everytime, see above and below.

Actual results:
Kernel update removes spaces from default boot entry (and breaks default)

Expected results:
Non-broken behaviour like in good old times like with GRUB 1.
Comment 1 Sergio Monteiro Basto 2012-03-20 21:53:45 EDT
this is a duplicated of bug #742720 ?
Comment 2 Robert Scheck 2012-03-21 05:33:28 EDT

*** This bug has been marked as a duplicate of bug 742720 ***

Note You need to log in before you can comment on or make changes to this bug.