Bug 783862 - programlistings are not evenly spaced between other elements
programlistings are not evenly spaced between other elements
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-22 19:23 EST by Darrin Mison
Modified: 2012-10-30 23:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
as it appears in html currently (0.3em) (51.55 KB, image/png)
2012-01-22 19:23 EST, Darrin Mison
no flags Details
html when margin is set to 1em (51.85 KB, image/png)
2012-01-22 19:24 EST, Darrin Mison
no flags Details
How the PDF of the same content looks currently (112.35 KB, image/png)
2012-01-22 19:24 EST, Darrin Mison
no flags Details

  None (edit)
Description Darrin Mison 2012-01-22 19:23:08 EST
Description of problem:
If you have a program listing between two paragraphs, the spacing is not uneven.  There is less space after the a program listing than after a paragraph.  This looks odd.  I can only definitively see this in html because I can use an inspector to view the CSS values.  PDF I am not sure about completely, but it does look strange if an admonition follows a program listing.  


Example:

<para>para 1</para>
<programlisting>listing 1</programlisting>
<para>para 2</para>
<programlisting>listing 2</programlisting>
  
Actual results:
In the HTML output there is less space between the listing and the 2nd paragraph than the 1st paragraph and the listing.

Expected results:

The paragraphs and program listings are evenly spaced.

Additional info:

This seems to be fixable in html by changing common.css, so there is the same margin after pre blocks as others.

from 

      pre {
         margin-bottom: 0.3em;
      }

to 

      pre {
         margin-bottom: 1em;
      }
Comment 1 Darrin Mison 2012-01-22 19:23:49 EST
Created attachment 556834 [details]
as it appears in html currently (0.3em)
Comment 2 Darrin Mison 2012-01-22 19:24:29 EST
Created attachment 556835 [details]
html when margin is set to 1em
Comment 3 Darrin Mison 2012-01-22 19:24:56 EST
Created attachment 556836 [details]
How the PDF of the same content looks currently
Comment 4 Ruediger Landmann 2012-03-12 19:41:19 EDT
Thanks Darrin; moving this upstream.
Comment 5 Jeff Fearn 2012-03-13 01:53:14 EDT
This looks to have been fixed in P3 by the general restyle.
Comment 6 Misha H. Ali 2012-04-22 17:25:52 EDT
Verified equality of vertical space between pata and programlisting elements presented as example in c#1.

Verified on:

OS: Fedora 16
Publican: 3.0
Release designation: publican-3.0-0.fc16.t166.src.rpm

Note You need to log in before you can comment on or make changes to this bug.