Bug 78390 - ATI Xpert 2000 or drivers caused Gnome locks
ATI Xpert 2000 or drivers caused Gnome locks
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glxMesa (Show other bugs)
8.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-22 00:01 EST by Need Real Name
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 18:09:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-22 00:01:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Usually after installing something, for example ePsxe, the system seems to
arbitrarily lock.  The mouse still moves, but absolutely nothing I do has any
effect.  I *think* the Samba server is still running during this stall.  (The
screen saver doesn't start, but I'm not sure if that's relevant.)

Once, while playing an MP3 using Winplay3 inside Wine, the system stalled, but
the music kept playing.

It doesn't seem to matter how much I'm running, except that the freeze seems to
happen only when I'm not doing much.  It happens almost exclusively when running
Nautilus, but once it did otherwise.

Two more funny things...

I ran up2date, which crashed about five times, but fortunately it's designed so
I don't have to keep re-downloading stuff. (something Microsoft should have
learned by now)  The freezing is not gone, but it's noticeably less frequent. 
(The kernel before update was ..-14 and now is ..-18.)

After about an hour, the system will wake up and start working again!  I don't
think I've had more than one stall per session.

I wish I could pin down what's going on.  It feels like a hardware problem, like
an IRQ on a network card or something, but the only piece of hardware that Linux
doesn't handle flawlessly is the sound card.  It's a Creative Labs Live Value,
and KMid (GM, not GS) stops responding when I try starting a MIDI file.  Plus,
Wine always complains about the MIDI.

System:
AMD Athlon T-Bird 1.4
512MB RAM
IBM 10GB + WD 80GB
Verbatim 48x12x50x CD-RW (CD roaster doesn't like the burnpoof)
CL Live Value PCI
ATI Xpert 2000 w/ 32MB
Jetway 876? mommyboard
D-Link 530+ PCI network card
3.5" sloppy drive

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Download and install ePsxe
2.(Attempt to run)
3.Start roaming around in Nautilus or the GNOME Menu
	

Actual Results:  Sorry, it's a little too consistent to try right now.  I have a
browser window full of text.

Additional info:

During lock-up, four things have still shown life: The mouse (always), the hard
drive light (always, blinks about once per minue), Winplay3 in Wine (once), and
Geyes (once).

I set the severity to normal, because whenever it crashes in the middle of
something I desperately need to keep, I just  leave it for an hour or so.  It
seems to consistently come back to life.
Comment 1 Need Real Name 2002-11-22 23:12:33 EST
Update!

Firstly, the Samba server Does still run when the computer freezes (totally
cool), but it runs pretty slowly.

A huge amount of my trouble stemmed from a screensaver of all things!  Kumppa
would run for half a second and then freeze.

The first kernel (the -14) did have the freezing problem with Nautilus, just
like the patch said, and the patch almost completely eliminated that problem. 
(Overall, I have had a lot of freezes!  About 45% were in Nautilus, about 45%
were in the screen saver, about 5% were during file installations, and about 5%
were just from clicking something on the desktop.  Fortunately, just about
everything is fixed.  Thanks for the updates.  You're much speedier than MS.)

I'd like a fix for Kumppa, since I usually have the screen saver randomize. 
Otherwise, I'll try to figure out how to remove it.  I'm still learning this system.

(I hope I picked the right radio button of Modified.)
Comment 2 Need Real Name 2002-12-06 21:18:22 EST
It turns out that my "fix" was only temporary and the lockups simply got more
and more frequent.  I tried removing all services, changing settings, etc.  It
turned out that it was either my ATI Xpert 2000 or the drivers that come with
RH8.  I've found other bugs on Bugzilla (I can't get the search to work anymore,
so I don't have any numbers for you).  One of the bugs received the response
that all (or just about all) ATI cards were tested to work flawlessly with RH. 
This opens up the possibilities that the cards have a unique way of
malfunctioning that only effects Red Hat Linux drivers or that the problem is
the video card in combination with some other piece of hardware.

Here's what I found, though.  Bare and updated installations had this problem,
as well as alternate ATI drivers (which may very well be the same driver).  On
my system (Red Hat 8.0, Athlon T-Bird 1.2, 512MB RAM, 80GB, SB Live Value,
D-Link Network card, Verbatim 48x24x50x CD-R, and Jetway 867 motherboard),
running Kumppa always causes lockup.  On my little brother's system (Red Hat
8.0, Athlon Duron 800, 256MB RAM, 10GB, Turtle Beach Tropez+, Linksys Network
card, Actima DVD-ROM, and Abit KT7A), it would pause when the GL/Mesa (whatever)
drivers are NOT loaded (such as when I switch video cards), but it would lock
when the drivers are loaded (I reinstalled RH8).  (I anticipate the same result
from my computer if I play with the drivers, but it's an enormous hassle to do so.)

Hardwarewise, in my system, I've eliminated the SB Live and CD-R.  I'm almost
certain it's either drivers or the video card, and I'm leaning towards drivers,
since the card runs almost flawlessly in Winblows 98.  I must say, though, that
while using 98 I did have a few unexplained lockups, but I think that they're
most likely from old RAM I was using, since RH didn't lock up...just Gnome.

After installing a TNT2 M64 (drivers were a chore), my system works perfectly.

And yes, my 11 yr old sister and 12 yr old brother use Red Hat Linux to do
everything they used to do with Windoze, and more, and they're not even computer
savvy.  In fact, my little brother installed his himself.  We don't have any
dual boot systems here.  ;-)  Nice job, Red Hat!  (Now if we could just make
configuration GUIs for everything so that the wonderful command line doesn't
need to be learned by everyone, I'd be in total bliss, but unfortunately then I
wouldn't have much need to buy any Red Hat literature or take any classes.)

I changed severity to high, since lockups result in loss of data in applications
and changed component to glxMesa, since that's the closest thing I can figure
out.  A possible workaround is to change to another video card, install RH, and
switch to the ATI card.  It's probably pretty easy to remove the glx, but when I
tried I got reboots instead of lockups.

If you need me to do anything extra or would like me to send them the video
card, let me know.
Comment 3 Brian Brock 2003-02-17 22:09:02 EST
Changing bug state to assigned, this bug isn't ready for QA verification.

Note You need to log in before you can comment on or make changes to this bug.