Bug 784054 - Parser for PHP >= 5.3.0
Summary: Parser for PHP >= 5.3.0
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-phpeclipse
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-23 16:54 UTC by Remi Collet
Modified: 2013-08-31 16:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-31 16:18:36 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Remi Collet 2012-01-23 16:54:35 UTC
phpeclipse parser works well for php < 5.3.0 code

php 5.2.x is EOL for some time
php 5.3.0 is current stable version since June 2009
php 5.4.0 will be the new stable version in a few weeks

So I create this bug, mostly as a tracker.

As upstream seems inactive, I will try to work on some patch for the internal parser...

Example: $classname::methodename() is a valid 5.3 syntaxe

Do you think it worth the work ?

Comment 1 Mat Booth 2012-02-08 19:19:43 UTC
Yeah upstream is really hard work. I think it would be better to work on getting Eclipse PDT into Fedora so we can obsolete this package.

Comment 2 Fedora End Of Life 2013-01-16 13:34:46 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Fedora End Of Life 2013-04-03 14:55:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Comment 4 Mat Booth 2013-08-31 16:18:36 UTC
This package has been retired:

http://pkgs.fedoraproject.org/cgit/eclipse-phpeclipse.git/tree/dead.package

Please consider using eclipse-pdt instead. It is currently under review and will hopefully make it into Fedora soon, see bug 1003188


Note You need to log in before you can comment on or make changes to this bug.