Bug 784089 - [abrt] kernel: [ INFO: possible recursive locking detected ] lock(&(&dentry->d_lock)->rlock);
Summary: [abrt] kernel: [ INFO: possible recursive locking detected ] lock(&(&dentry->...
Keywords:
Status: CLOSED DUPLICATE of bug 714828
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ian Kent
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f591aaf59cc13f4717554565d0c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-23 19:26 UTC by Frank Murphy
Modified: 2012-02-14 01:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-14 01:43:34 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Similar error with kernel 3.3-* (4.43 KB, text/plain)
2012-02-03 22:35 UTC, Frank Murphy
no flags Details

Description Frank Murphy 2012-01-23 19:26:41 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.1-8.fc17.i686 root=/dev/mapper/luks-481de494-113f-4350-92d8-f1e5ad1fd2fc ro SYSFONT=latarcyrheb-sun16 LANG=en_IE.UTF-8 KEYTABLE=uk telinit 3
comment:        Was waiting for me on bootup. Graphical boot.
event_log:      2012-01-23-19:24:51> Smolt profile successfully saved
kernel:         3.2.1-8.fc17.i686
reason:         [ INFO: possible recursive locking detected ]
time:           Mon 23 Jan 2012 19:04:55 GMT

backtrace:
:[ INFO: possible recursive locking detected ]
:3.2.1-8.fc17.i686 #1
:---------------------------------------------
:automount/5686 is trying to acquire lock:
: (&(&dentry->d_lock)->rlock/1){+.+...}, at: [<c0620515>] autofs4_expire_indirect+0xc5/0x640
:but task is already holding lock:
: (&(&dentry->d_lock)->rlock/1){+.+...}, at: [<c0620515>] autofs4_expire_indirect+0xc5/0x640
:other info that might help us debug this:
: Possible unsafe locking scenario:
:       CPU0
:       ----
:  lock(&(&dentry->d_lock)->rlock);
:  lock(&(&dentry->d_lock)->rlock);
: *** DEADLOCK ***
: May be due to missing lock nesting notation
:2 locks held by automount/5686:
: #0:  (&(&sbi->lookup_lock)->rlock){+.+...}, at: [<c06204d2>] autofs4_expire_indirect+0x82/0x640
: #1:  (&(&dentry->d_lock)->rlock/1){+.+...}, at: [<c0620515>] autofs4_expire_indirect+0xc5/0x640
:stack backtrace:
:Pid: 5686, comm: automount Not tainted 3.2.1-8.fc17.i686 #1
:Call Trace:
: [<c04906af>] __lock_acquire+0x152f/0x1650
: [<c0620515>] ? autofs4_expire_indirect+0xc5/0x640
: [<c049095a>] ? lock_release_non_nested+0x18a/0x2a0
: [<c0620515>] ? autofs4_expire_indirect+0xc5/0x640
: [<c0490d80>] lock_acquire+0x80/0x180
: [<c0620515>] ? autofs4_expire_indirect+0xc5/0x640
: [<c099a684>] _raw_spin_lock_nested+0x44/0x80
: [<c0620515>] ? autofs4_expire_indirect+0xc5/0x640
: [<c0620515>] autofs4_expire_indirect+0xc5/0x640
: [<c048c4ab>] ? trace_hardirqs_off+0xb/0x10
: [<c0620d87>] autofs4_do_expire_multi+0xb7/0xf0
: [<c0473e32>] ? __task_pid_nr_ns+0xa2/0xe0
: [<c0621191>] autofs_dev_ioctl_expire+0x21/0x30
: [<c0621170>] ? autofs_dev_ioctl_askumount+0x30/0x30
: [<c0621532>] autofs_dev_ioctl+0x252/0x360
: [<c0639513>] ? file_has_perm+0xe3/0xf0
: [<c0621170>] ? autofs_dev_ioctl_askumount+0x30/0x30
: [<c06212e0>] ? autofs_dev_ioctl_closemount+0x20/0x20
: [<c0565e8f>] do_vfs_ioctl+0x7f/0x5d0
: [<c06397c2>] ? selinux_file_ioctl+0x62/0x130
: [<c0566448>] sys_ioctl+0x68/0x80
: [<c099b354>] syscall_call+0x7/0xb

smolt_data:
:
:
:General
:=================================
:UUID: 549b0a57-25bf-44a3-ba74-c3563723fdf7
:OS: Fedora release 17 (Rawhide)
:Default run level: Unknown
:Language: en_IE.UTF-8
:Platform: i686
:BogoMIPS: 4804.75
:CPU Vendor: GenuineIntel
:CPU Model: QEMU Virtual CPU version 1.0
:CPU Stepping: 3
:CPU Family: 6
:CPU Model Num: 3
:Number of CPUs: 1
:CPU Speed: 2401
:System Memory: 2006
:System Swap: 3037
:Vendor: Bochs
:System: Bochs 
:Form factor: Other
:Kernel: 3.2.1-8.fc17.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(6900:4098:6900:5) pci, virtio-pci, RAM, Virtio memory balloon
:(6966:256:6900:4352) pci, None, VIDEO, N/A
:(6900:4099:6900:3) pci, virtio-pci, SIMPLE, Virtio console
:(6900:4096:6900:1) pci, virtio-pci, ETHERNET, Virtio network device
:(32902:9237:32902:0) pci, snd_intel8x0, MULTIMEDIA_AUDIO, 82801AA AC'97 Audio Controller
:(32902:4663:6900:4352) pci, None, HOST/PCI, Qemu virtual machine
:(6900:4097:6900:2) pci, virtio-pci, SCSI, Virtio block device
:(32902:28704:6900:4352) pci, uhci_hcd, USB, Qemu virtual machine
:(32902:28688:6900:4352) pci, ata_piix, STORAGE, Qemu virtual machine
:(32902:28672:6900:4352) pci, None, PCI/ISA, Qemu virtual machine
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/luks-481de494-113f-4350-92d8-f1e5ad1fd2fc / ext4 4096 4096 6814567 5563370 5495165 1712128 1593103 1593103
:/dev/vda1 /boot ext4 4096 4096 523290 424123 397909 131072 130793 130793
:

Comment 1 Josh Boyer 2012-02-02 14:18:01 UTC
Ian, any idea if this is still a problem in 3.3?

Comment 2 Ian Kent 2012-02-02 14:51:15 UTC
(In reply to comment #1)
> Ian, any idea if this is still a problem in 3.3?

I can't see the patch that has posted a couple of times now
in the upstream source. I'm not sure why it has been ignored
or if people think the patch is not the right way to resolve
it because I got no feedback either.

I guess I can try again (as soon as I get a chance) by sending
it to Al Viro.

Comment 3 Frank Murphy 2012-02-03 22:35:07 UTC
Created attachment 559380 [details]
Similar error with kernel 3.3-*

Didn't want to create a new bug.
VM created as F16.Xfce clean install yesterday.
Did the /convertfs thing,
 yum update f17-usrmove.repo

Comment 4 Josh Boyer 2012-02-14 01:43:34 UTC

*** This bug has been marked as a duplicate of bug 714828 ***


Note You need to log in before you can comment on or make changes to this bug.