Bug 784198 - Disadvantageous SplashScreen on DualMonitor
Disadvantageous SplashScreen on DualMonitor
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 03:47 EST by Rolle
Modified: 2012-03-13 04:24 EDT (History)
11 users (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-8.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 19:21:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolle 2012-01-24 03:47:43 EST
Description of problem:
I have 2 Monitors enabled. When I start LibreOffice the splashscreen is centred between the two monitors. I think it is disadvantageous, because it looks not very nice, when the splashscreen is splitted between the two monitors.

Version-Release number of selected component (if applicable):
Fedora 16

How reproducible:
everytime

Steps to Reproduce:
1. connect 2 monitors
2. don't activate the clone-mode for the monitors
3. start LibreOffice
  
Actual results:
The splashscreen of LibreOffice is centred between the 2 monitors (splitted  between the monitors)

Expected results:
The splashscreen should appear only on that monitor (only on one monitor), where the application is afterwards displayed.

Additional info:
It's not a bug, it's cosmetic design.
Comment 1 Owen Taylor 2012-01-24 09:36:59 EST
Suspect this is a LibreOffice problem - haven't seen any other reports of Mutter placing things over the crack between monitors.
Comment 2 David Tardon 2012-01-24 10:25:52 EST
Yes, the (new) splash screen did not take into account xinerama info. It is definitely fixed in 3.5 and possibly in 3.4.5 . The fix is relatively simple so I will backport it if it is not.
Comment 3 David Tardon 2012-03-06 08:25:32 EST
Bah, forgot about this... Will be fixed in >=libreoffice-3.4.5.2-8.fc16 .
Comment 4 Fedora Update System 2012-03-07 05:21:59 EST
libreoffice-3.4.5.2-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.5.2-8.fc16
Comment 5 Fedora Update System 2012-03-07 22:54:21 EST
Package libreoffice-3.4.5.2-8.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.5.2-8.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3267/libreoffice-3.4.5.2-8.fc16
then log in and leave karma (feedback).
Comment 6 Tim Waugh 2012-03-08 04:45:17 EST
Thanks, works fine here.
Comment 7 Fedora Update System 2012-03-09 19:21:09 EST
libreoffice-3.4.5.2-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Rolle 2012-03-13 04:24:01 EDT
Works fine here too. Thanks for the good work.

Note You need to log in before you can comment on or make changes to this bug.