Bug 78425 - cursor is blue when aumix exits
cursor is blue when aumix exits
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: aumix (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-22 13:22 EST by David Balažic
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version: 2.8-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-29 23:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
this patch corrects the blue cursor (simply prints a carriage return to refresh terminal's new BG/FG color setting) (622 bytes, patch)
2002-11-25 11:19 EST, Michael Lee Yohe
no flags Details | Diff

  None (edit)
Description David Balažic 2002-11-22 13:22:26 EST
Description of Problem:

After exiting aumix , the cursor is blue. The typed characters are white and 
after pressing "return" the cursor color goes to "white" , as it was before 
aumix.

Version-Release number of selected component (if applicable):

aumix-2.7-12

How Reproducible:

allways

Steps to Reproduce:
1. run aumix on console ( VT1 )
2. exit aumix
3. 

Actual Results:

The color of the cursor is blue. After pressing return , it goes to white.

Expected Results:

Cursor is white.

Additional Information:
Comment 1 Michael Lee Yohe 2002-11-22 13:50:01 EST
Confirming.

$ rpm -q aumix
aumix-2.7-12

Severity should be trivial, and the priority should be low.
Comment 2 Mike A. Harris 2002-11-22 23:01:17 EST
Hmm.  This is the same version of aumix we've shipped for years.  Nothing
has changed.  Perhaps it is a bash bug.
Comment 3 David Balažic 2002-11-23 10:10:31 EST
yes, the bug is also very old. I remember seeing it with earlier RHL releases.
It is not related to bash, I chsh'ed to /bin/tcsh and it behaves the same.
Comment 4 Mike A. Harris 2002-11-23 11:25:58 EST
Hmm. I can't reproduce it on a 7.1 box here, or 8.0.  I believe you
that the bug is present, I just wonder what is different about my
setup.  Perhaps it is my custom bash prompt.

I just tried using "csh" also.  Now I'll try invoking as tcsh...

No go.  This is all inside KDE's konsole.  Perhaps it is specific
to a particular terminal emulator, or perhaps the Linux console?

AHA!  I just went to the console in bash, and ran aumix.  When I
quit the program, I get my normal prompt, followed by a blue cursor.
Pressing enter, goes up a line and restores the cursor to its proper
color, as does typing something and pressing backspace.

I have not looked at the aumix source code yet, however I can
pretty much guess what is happening is that the program is doctoring
with the Linux console cursor codes and not restoring them properly.
Either that or it is dirtying the entire background, and then not
restoring properly.  Ultimately, the program should really save the
entire screen contents, as do pine/mc/or any other sane full screen
ncurses based application.

(Wait..  did I just say pine and mc are sane?  <cringe>)

So in the end, I acknowledge this 'glitch'.  It it however very
trivial in the grand scheme of things, and something I would
ordinarily recommend filing with the upstream maintainer, except
for the fact that aumix has not been updated in over 2 years, and
seems unmaintained.  So I'll leave it here and maybe poke at it
when I'm bored or something.

In the mean time, if anyone else is up to the task, feel free to
submit a patch.
Comment 5 Michael Lee Yohe 2002-11-25 11:19:07 EST
Created attachment 86345 [details]
this patch corrects the blue cursor (simply prints a carriage return to refresh terminal's new BG/FG color setting)
Comment 6 Mike A. Harris 2003-05-29 23:29:19 EDT
Fixed in rawhide 2.8-3

Note You need to log in before you can comment on or make changes to this bug.