Bug 78426 - 8.0 i386 cd and boot floppy hang at install startup
8.0 i386 cd and boot floppy hang at install startup
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-22 13:28 EST by jeff
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 16:26:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeff 2002-11-22 13:28:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
I have a digital celebris gl 6180, which is a pentium pro 180mhz
system. It has 96mb of ram, and is currently running
win 98se, win 2000 pro, and win xp pro.
I have successfully installed 7.3 on it (except the network
card didn't work). I tried to install 8.0.
The cd hung during booting with the error:
Isolinux 1.75 2002-06-14
isolinux: Loading spec packet failed, trying to wing it....
isolinux: Found something at drive = 9F
isolinux: Looks like it might be right, continuing...
isolinux: Inage checksum error, sorry...
Boot failed: press a key to retry

I know the cd is ok, because I successfully installed 8.0 on a
different machine. I know the computer is ok, because I successfully
booted from the 7.3 cd right after that.

I then tried a boot floppy.
I got the following:
Loading vmlinux...
Boot failed: please change disks and press a key to continue

I therefore conclude that the 8.0 cd 1 has a problem with some
computers. I also conclude that the 8.0 boot.img floppy has a similar
problem with some computers.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
	

Actual Results:  I cannot boot from 8.0 cd or floppy.
I can boot from 7.3 cd.
I can boot from 8.0 cd on a different machine.
The digital celebris machine is ok, as it is currently running
windows 98 se, windows 2000 pro, and windows xp pro.


Expected Results:  I should be able to install 8.0

Additional info:

I have 3 of these machines, and I would like to build a mini-beowulf
cluster with them, so please fix the problem.
Comment 1 Michael Lee Yohe 2002-11-22 13:52:03 EST
Well - if you conclude that the CDs are prim-and-proper, I would attempt to
replace the CD-ROM drive with one that you know works well.  That would isolate
the fault to the discs themselves, the CD-ROM drive, or the hardware controller
for the drive.
Comment 2 jeff 2002-11-22 14:16:48 EST
I have tested the cd rom drive under windows 2000,
and it works perfectly.
I can successfully boot with the rh 7.3 cd.
And I cannot boot with the rh8.0 boot floppy.
Therefore, I conclude the problem has nothing to do with the
cd rom drive. I think some changes were made between 7.3 and 8.0
which prevents this computer from booting.

On a different computer, I used the rh8.0 cds to successfully install
yesterday, so I know the cds are ok.
Comment 3 Jeremy Katz 2002-11-26 17:45:46 EST
This is a BIOS bug in that it doesn't properly implement the spec necessary to
handle El Torito hard drive image booting.
Comment 4 jeff 2002-11-26 19:01:32 EST
Is this BIOS bug also responsible for the floppy image not booting?
Why can I boot with a redhat 7.3 install cd?
Comment 5 jeff 2002-11-27 13:58:05 EST
Why does windows 98, 2000, and xp boot disks work?
If microsoft can deal with this 'bios bug', why can't redhat?
Comment 6 Jeremy Katz 2003-01-03 00:04:32 EST
Does the recent beta (Phoebe) work better?
Comment 7 jeff 2003-01-05 19:25:16 EST
No.
It tries to boot and says:
ISO Linux 2.00 2002-10-25 isolinux: loading spec packet failed, trying to wing it
Found something at drive=9F looks like it might be right, continuing
Image checksum error, sorry

I verified the md5 check sum was correct.
Comment 8 Jeremy Katz 2003-01-12 15:51:23 EST
This error comes only if the BIOS improperly reads sectors off the CD when
trying to read the boot sector

As for your earlier floppy failures, those look like failing floppy or drive
problems because it started to load the kernel and then failed partway through.
Comment 9 jeff 2003-01-12 16:21:18 EST
I just tested my system again. It boots fine from the 7.3 cd.
So the BIOS knows how to read the rh7.3 cd.

It also boots fine from all windows cd's including windows 98 and windows 2000.
So the BIOS also knows how to read these cd's.

The floppy drive works fine also, because I have booted other operating systems
with the fd. Today I booted from floppy mandrake 8.1 as well as openbsd 3.1 .

So I really think the problem lies with red hat 8.0, not my hardware.

Since I have problems with the 8.0 cd (which is known good as I installed
it on two different machines), as well as the phoebe cd, I don't think there
is a flaw on my cd's.

    jeff deifik
Comment 10 Jeremy Katz 2003-01-12 16:26:37 EST
7.3 uses a floppy-emulation based method of booting.  8.0 later uses hard drive
emulation.  Both of these are covered and required for proper adherance to the
El Torito spec for bootable CDs.  The fact that things that use floppy emulation
boot fine doesn't mean that your BIOS isn't buggy.

Note You need to log in before you can comment on or make changes to this bug.