Bug 784269 - conflict between glib2-devel.i686 and glib2-devel.x86_64
conflict between glib2-devel.i686 and glib2-devel.x86_64
Status: CLOSED DUPLICATE of bug 718404
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 07:22 EST by Igor Bukanov
Modified: 2012-02-16 11:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-16 11:30:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Igor Bukanov 2012-01-24 07:22:10 EST
Description of problem:

I cannot install both glib2-devel.i686 and glib2-devel.x86_64 on the same 64-bit system using yum due to file conflict 

Version-Release number of selected component (if applicable):

glib2-devel-2.30.2-1

How reproducible:

always

Steps to Reproduce:

yum install glib2-devel.i686 and glib2-devel.x86_64

Actual results:

Transaction Check Error:
  file /usr/bin/gdbus-codegen conflicts between attempted installs of glib2-devel-2.30.2-1.fc16.i686 and glib2-devel-2.30.2-1.fc16.x86_64
  file /usr/share/glib-2.0/gdb/glib.pyc conflicts between attempted installs of glib2-devel-2.30.2-1.fc16.i686 and glib2-devel-2.30.2-1.fc16.x86_64
  file /usr/share/glib-2.0/gdb/glib.pyo conflicts between attempted installs of glib2-devel-2.30.2-1.fc16.i686 and glib2-devel-2.30.2-1.fc16.x86_64
  file /usr/share/glib-2.0/gdb/gobject.pyc conflicts between attempted installs of glib2-devel-2.30.2-1.fc16.i686 and glib2-devel-2.30.2-1.fc16.x86_64
  file /usr/share/glib-2.0/gdb/gobject.pyo conflicts between attempted installs of glib2-devel-2.30.2-1.fc16.i686 and glib2-devel-2.30.2-1.fc16.x86_64
  file /usr/share/systemtap/tapset/glib.stp conflicts between attempted installs of glib2-devel-2.30.2-1.fc16.i686 and glib2-devel-2.30.2-1.fc16.x86_64
  file /usr/share/systemtap/tapset/gobject.stp conflicts between attempted installs of glib2-devel-2.30.2-1.fc16.i686 and glib2-devel-2.30.2-1.fc16.x86_64


Expected results:

Both packages are installed 

Additional info:

I was able to workaround that using yumdownload and rpm -i --replacefiles to install i686 version separately after installing x86_64. However, this workaround is not persistent and is necessary to do each time glib2-devel package is updated.
Comment 1 Matthias Clasen 2012-02-16 11:30:15 EST

*** This bug has been marked as a duplicate of bug 718404 ***

Note You need to log in before you can comment on or make changes to this bug.