Bug 784307 - setroubleshootd needs to be allowed to execute rpm
setroubleshootd needs to be allowed to execute rpm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.8
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 09:21 EST by Miroslav Grepl
Modified: 2012-02-21 00:49 EST (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-327.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:49:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miroslav Grepl 2012-01-24 09:21:06 EST
Description of problem:

setroubleshootd running as setroubleshootd_t will need to execute rpm with rpm_exec_t context because of setroubleshoot fast changes in RHEL5.9


Version-Release number of selected component (if applicable):


How reproducible:

Get a new setroubleshoot build, generate AVC msg and make sure you won't get AVC msgs related to setroubleshootd_t and rpm_exec_t.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miroslav Grepl 2012-01-24 09:31:14 EST
Easy fix.
Comment 5 Miroslav Grepl 2012-01-24 18:21:13 EST
Fixed in selinux-policy-2.4.6-327.el5
Comment 8 errata-xmlrpc 2012-02-21 00:49:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0158.html

Note You need to log in before you can comment on or make changes to this bug.