Bug 78432 - additons to applet cause improper resizing of panel
additons to applet cause improper resizing of panel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
David Lawrence
http://stick.miscellaneous.net/Screen...
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-22 14:34 EST by chrism
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 02:26:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Not having that problem - mine works fine. (15.58 KB, image/png)
2002-11-22 17:08 EST, Michael Lee Yohe
no flags Details

  None (edit)
Description chrism 2002-11-22 14:34:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
This applet is also home for several other applets as well.
Including the keyring applet (when you enter the root pw) as well as the 
gaim-applet icon (v0.60)

If you have your panel size set to Xsmall or Small (anything below medium) and
an icon gets added additional icons are stacked on top of the RHN icon.  This
causes the panel to grow 1 or 2 orders of magnatude (depends on the number of
icons it's trying to display)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enable the RHN applet
2. lauch an application that prompts you for the root pw (Internet Configuration
Wizard under System tools is a good one to use)
3. enter root pw

	

Actual Results:  Keyring Icon appears below the RHN applet icon
and panel size changes.

Expected Results:  since the panel is smaller is should have appeared to the
left or right of the rhn applet icon.  Panel should stay the same size.

Scaling of the icon seems to work fine it's just the positioning

Additional info:
Comment 1 Michael Lee Yohe 2002-11-22 17:08:32 EST
Created attachment 86124 [details]
Not having that problem - mine works fine.
Comment 2 chrism 2002-12-02 00:36:03 EST
bug only seems to appear if the panel in question is on the top edge of the
screen.  Having the panel on the bottom screen edge causes the additional icons
to position correctly.  Moving the panel from top to bottom and back to top
again also causes the icons to position correctly, but only for the duration of
that session.  (restarting it happens all over again)
Comment 3 Daniel Veillard 2003-09-28 16:36:47 EDT
Sounds like a packing problem for the notification-area-applet which
is part of the gnome-panel,

Daniel
Comment 4 Leonard den Ottolander 2004-02-26 07:32:57 EST
This has been solved in FC 1 (maybe even RH 9). Maybe this should be
closed NEXTRELEASE?

Note You need to log in before you can comment on or make changes to this bug.