Bug 784343 - upgrade needs better check for "server is running"
Summary: upgrade needs better check for "server is running"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-24 16:06 UTC by Rich Megginson
Modified: 2012-06-20 07:13 UTC (History)
3 users (show)

Fixed In Version: 389-ds-base-1.2.10.0-1.el6
Doc Type: Bug Fix
Doc Text:
Note: this was added to better support systemd on Fedora 16 and later, so the only testing required for RHEL 6.3 is to make sure there are no regressions.
Clone Of:
Environment:
Last Closed: 2012-06-20 07:13:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2012:0813 normal SHIPPED_LIVE Low: 389-ds-base security, bug fix, and enhancement update 2012-06-19 19:29:15 UTC

Description Rich Megginson 2012-01-24 16:06:28 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/264

The upgrade scripts currently just look to see if the .pid file is present, and assume if that file is present the server is running.  But under certain conditions, the .pid file is still there even when the server is down (old systemd implementation) - so the upgrade scripts need to test to see if the process id is still present.

Note: this was added to better support systemd on Fedora 16 and later, so the only testing required for RHEL 6.3 is to make sure there are no regressions.

Comment 2 Jenny Severance 2012-01-24 16:50:10 UTC
Please add steps to reproduce/verify this bug.
Thanks

Comment 4 Rich Megginson 2012-04-16 16:27:38 UTC
(In reply to comment #2)
> Please add steps to reproduce/verify this bug.
> Thanks

Just verify that upgrade from RHEL 6.2 to RHEL 6.3 for 389-ds-base works.

Comment 5 Amita Sharma 2012-04-24 07:02:49 UTC
I have tested this upgrade and it worked fine for me.
Hence marking the bug as VERIFIED.

Comment 6 Rich Megginson 2012-05-24 23:07:04 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Note: this was added to better support systemd on Fedora 16 and later, so the only testing required for RHEL 6.3 is to make sure there are no regressions.

Comment 7 errata-xmlrpc 2012-06-20 07:13:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2012-0813.html


Note You need to log in before you can comment on or make changes to this bug.