Bug 784345 - [abrt] kernel: BUG: scheduling while atomic: swapper/0/0/0x10000100
[abrt] kernel: BUG: scheduling while atomic: swapper/0/0/0x10000100
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:833e63a1c8f09aab1f45a046de0...
:
: 784362 784404 784417 784491 784606 784669 784681 784755 784808 784884 785121 785311 786658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 11:09 EST by Jimmy Dorff
Modified: 2012-02-02 08:57 EST (History)
24 users (show)

See Also:
Fixed In Version: kernel-3.2.2-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-27 22:33:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt log from error with 3.2.0-2.fc17.x86_64 (6.38 KB, text/plain)
2012-01-24 16:39 EST, Jimmy Dorff
no flags Details
abrt log from error with 3.2.0-2.fc17.x86_64 debug (5.03 KB, application/octet-stream)
2012-01-24 19:29 EST, Jimmy Dorff
no flags Details
var log messages for various kernels including the 3.2.0-2.fc17 with various programs giving sched atomic error for kernel (1.30 MB, text/plain)
2012-01-25 03:45 EST, collura
no flags Details
realtek_async_autopm.patch (616 bytes, text/plain)
2012-01-25 12:57 EST, Stanislaw Gruszka
no flags Details
dmesg for kernel-3.2.1-3.fc16.x86_64 does have the 'scheduling while atomic' errors for various programs (124.06 KB, text/plain)
2012-01-26 05:34 EST, collura
no flags Details
dmesg for kernel-3.2.1-4.1.fc16.x86_64 fixes the 'scheduling while atomic' error for me as well thanks :') (66.75 KB, text/plain)
2012-01-26 05:36 EST, collura
no flags Details
dmesg for kernel-3.2.2-1.fc16.x86_64 seems 'scheduling while atomic' error still fixed :') (66.67 KB, text/plain)
2012-01-27 15:29 EST, collura
no flags Details

  None (edit)
Description Jimmy Dorff 2012-01-24 11:09:23 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.1-3.fc16.x86_64 root=UUID=58c265ec-2dfd-4df1-a6ba-cca72e100bc9 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.2.1-3.fc16.x86_64
reason:         BUG: scheduling while atomic: swapper/0/0/0x10000100
time:           Tue 24 Jan 2012 11:08:01 AM EST

backtrace:
:BUG: scheduling while atomic: swapper/0/0/0x10000100
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse binfmt_misc lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xts gf128mul dm_crypt snd_hda_codec_hdmi snd_hda_codec_conexant arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_seq iwlwifi snd_seq_device snd_pcm mac80211 uvcvideo snd_timer cfg80211 videodev snd dell_wmi dell_laptop r8169 iTCO_wdt soundcore media sparse_keymap v4l2_compat_ioctl32 dcdbas microcode btusb bluetooth joydev i2c_i801 iTCO_vendor_support rfkill snd_page_alloc mii uinput sunrpc wmi ums_realtek usb_storage i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:CPU 0 
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse binfmt_misc lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xts gf128mul dm_crypt snd_hda_codec_hdmi snd_hda_codec_conexant arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_seq iwlwifi snd_seq_device snd_pcm mac80211 uvcvideo snd_timer cfg80211 videodev snd dell_wmi dell_laptop r8169 iTCO_wdt soundcore media sparse_keymap v4l2_compat_ioctl32 dcdbas microcode btusb bluetooth joydev i2c_i801 iTCO_vendor_support rfkill snd_page_alloc mii uinput sunrpc wmi ums_realtek usb_storage i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 0, comm: swapper/0 Not tainted 3.2.1-3.fc16.x86_64 #1 Dell Inc. Vostro V131/0C06WP
:RIP: 0010:[<ffffffff8130f6ed>]  [<ffffffff8130f6ed>] intel_idle+0xed/0x150
:RSP: 0018:ffffffff81a01e18  EFLAGS: 00000202
:RAX: 0000000000000000 RBX: ffffffff810936f9 RCX: 0000000000000000
:RDX: 0000000000000b45 RSI: 0000000000000000 RDI: 00000000002c07a2
:RBP: ffffffff81a01e78 R08: 00000000fffffffe R09: 0000000000000ef0
:R10: 0000000000000000 R11: 0000000000000000 R12: ffffffff8109f504
:R13: ffffffff81a01db8 R14: ffffffff8103206d R15: ffffffff81a01d78
:FS:  0000000000000000(0000) GS:ffff88021fa00000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 00000000028fe000 CR3: 0000000001a05000 CR4: 00000000000406f0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process swapper/0 (pid: 0, threadinfo ffffffff81a00000, task ffffffff81a0d020)
:Stack:
: 0000000000000000 0000000000000b45 0000000000000000 0000000000000000
: 0000000000000b45 00000000002c0443 0000006c1d893800 ffff88021fa1ac70
: 00000000fffffff0 0000000000000001 0000000000000000 000000000008c000
:Call Trace:
: [<ffffffff81491fe1>] cpuidle_idle_call+0xc1/0x280
: [<ffffffff8101322a>] cpu_idle+0xca/0x120
: [<ffffffff815be75e>] rest_init+0x72/0x74
: [<ffffffff81aebbfe>] start_kernel+0x3ba/0x3c5
: [<ffffffff81aeb347>] x86_64_start_reservations+0x132/0x136
: [<ffffffff81aeb140>] ? early_idt_handlers+0x140/0x140
: [<ffffffff81aeb44d>] x86_64_start_kernel+0x102/0x111
:Code: d8 ff 4c 29 f8 48 89 c7 e8 c1 42 d6 ff 4c 69 f0 40 42 0f 00 48 89 45 a0 48 89 55 a8 48 89 45 b8 48 89 55 c0 49 01 d6 fb 66 66 90 <66> 66 90 85 1d 72 f3 75 00 75 0e 48 8d 75 cc bf 05 00 00 00 e8 

smolt_data:
:
:
:General
:=================================
:UUID: 2d16bd22-53a7-484a-8f6a-276b323172ef
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4190.49
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2100
:System Memory: 7894
:System Swap: 9951
:Vendor: Dell Inc.
:System: Vostro V131 Not Specified
:Form factor: Portable
:Kernel: 3.2.1-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7243:4136:1296) pci, None, PCI/ISA, HM67 Express Chipset Family LPC Controller
:(4172:33345:4136:1296) pci, xhci_hcd, USB, N/A
:(32902:138:32902:21285) pci, iwlwifi, NETWORK, Centrino Wireless-N 1030 BGN
:(32902:278:4136:1296) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4136:1296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4136:1296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4136:1296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7198:4136:1296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 8
:(32902:7192:4136:1296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:4136:1296) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:4136:1296) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(4332:33128:4136:1296) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:7171:4136:1296) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:4136:1296) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4136:1296) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4136:1296) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4136:1296) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 8368581 7270380 6850950 2097152 1967281 1967281
:/dev/sda2 /boot ext4 1024 1024 508745 459799 434199 128016 127796 127796
:/dev/mapper/luks-edc19a6a-5c7c-4ff1-be36-59edd4eab04c /home ext4 4096 4096 8451812 8287698 7864082 2121728 2121433 2121433
:
Comment 1 Josh Boyer 2012-01-24 11:24:28 EST
Can you attach the full dmesg from this boot?

If you install kernel-debug, are there other tracebacks that show up?

This has been reported upstream as well, for both 3.2.1 and 3.3-rc1:

https://lkml.org/lkml/2012/1/24/83
https://lkml.org/lkml/2012/1/24/190
Comment 2 Josh Boyer 2012-01-24 12:43:16 EST
Also, out of curiosity could you try installing and booting this kernel and letting us know if you hit the same backtrace:

http://koji.fedoraproject.org/koji/buildinfo?buildID=281207

No need to rebuild.  Just install and boot.
Comment 3 Jimmy Dorff 2012-01-24 16:38:22 EST
Still happened with 3.2.0-2.fc17.x86_64 see attachment. I'm installing debuginfo package and see if that gives more detail.
Comment 4 Jimmy Dorff 2012-01-24 16:39:15 EST
Created attachment 557319 [details]
abrt log from error with 3.2.0-2.fc17.x86_64
Comment 5 Josh Boyer 2012-01-24 16:48:40 EST
(In reply to comment #3)
> Still happened with 3.2.0-2.fc17.x86_64 see attachment. 

Ugh.  Ok, so it happens with plain 3.2.

> I'm installing debuginfo package and see if that gives more detail.

Er, not debuginfo.  kernel-debug.  It's a kernel built with more debug options enabled.
Comment 6 Jimmy Dorff 2012-01-24 19:29:15 EST
Created attachment 557343 [details]
abrt log from error with 3.2.0-2.fc17.x86_64 debug
Comment 7 collura 2012-01-24 20:23:03 EST
*** Bug 784417 has been marked as a duplicate of this bug. ***
Comment 8 collura 2012-01-25 03:45:36 EST
Created attachment 557399 [details]
var log messages for various kernels including the 3.2.0-2.fc17 with various programs giving sched atomic error for kernel

line 0001 was from kernel-3.1.9-1.fc16.x86_64 no kernel-debug
line 1330 was from kernel-3.2.1-3.fc16.x86_64 no kernel-debug
line 2648 was from kernel-3.2.0-2.fc17.x86_64 with kernel-debug
Comment 9 Josh Boyer 2012-01-25 11:44:53 EST
(In reply to comment #6)
> Created attachment 557343 [details]
> abrt log from error with 3.2.0-2.fc17.x86_64 debug

Interesting.  Do you have the full dmesg from this boot?
Comment 10 Christian D 2012-01-25 12:04:22 EST
I am also experiencing this bug. I am running 3.2.1-3.fc16.x86_64
BUG: scheduling while atomic: swapper/3/0/0x10000100
Comment 11 Stanislaw Gruszka 2012-01-25 12:57:24 EST
Created attachment 557497 [details]
realtek_async_autopm.patch

Proposed patch, should fix:

: <IRQ>  [<ffffffff8105ee7a>] __might_sleep+0x13a/0x1f0
: [<ffffffffa00180b0>] ? rts51x_modi_suspend_timer+0x50/0x50 [ums_realtek]
: [<ffffffff813fdee3>] __pm_runtime_idle+0xa3/0xb0
: [<ffffffffa00180b0>] ? rts51x_modi_suspend_timer+0x50/0x50 [ums_realtek]
: [<ffffffff8146ed30>] usb_autopm_put_interface+0x30/0x40
: [<ffffffffa0018125>] rts51x_suspend_timer_fn+0x75/0x80 [ums_realtek]
Comment 12 Josh Boyer 2012-01-25 13:04:31 EST
(In reply to comment #11)
> Created attachment 557497 [details]
> realtek_async_autopm.patch
> 
> Proposed patch, should fix:
> 
> : <IRQ>  [<ffffffff8105ee7a>] __might_sleep+0x13a/0x1f0
> : [<ffffffffa00180b0>] ? rts51x_modi_suspend_timer+0x50/0x50 [ums_realtek]
> : [<ffffffff813fdee3>] __pm_runtime_idle+0xa3/0xb0
> : [<ffffffffa00180b0>] ? rts51x_modi_suspend_timer+0x50/0x50 [ums_realtek]
> : [<ffffffff8146ed30>] usb_autopm_put_interface+0x30/0x40
> : [<ffffffffa0018125>] rts51x_suspend_timer_fn+0x75/0x80 [ums_realtek]

OK.  I'll spin up a scratch build with this patch included for people to test out.
Comment 13 Josh Boyer 2012-01-25 13:15:43 EST
(In reply to comment #12)
> (In reply to comment #11)
> > Created attachment 557497 [details]
> > realtek_async_autopm.patch
> > 
> > Proposed patch, should fix:
> > 
> > : <IRQ>  [<ffffffff8105ee7a>] __might_sleep+0x13a/0x1f0
> > : [<ffffffffa00180b0>] ? rts51x_modi_suspend_timer+0x50/0x50 [ums_realtek]
> > : [<ffffffff813fdee3>] __pm_runtime_idle+0xa3/0xb0
> > : [<ffffffffa00180b0>] ? rts51x_modi_suspend_timer+0x50/0x50 [ums_realtek]
> > : [<ffffffff8146ed30>] usb_autopm_put_interface+0x30/0x40
> > : [<ffffffffa0018125>] rts51x_suspend_timer_fn+0x75/0x80 [ums_realtek]
> 
> OK.  I'll spin up a scratch build with this patch included for people to test
> out.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3732597

When the above build completes, please test it out.  Anyone reporting issues is welcome to, but particularly the original reporter.
Comment 14 Josh Boyer 2012-01-25 13:49:04 EST
*** Bug 784669 has been marked as a duplicate of this bug. ***
Comment 15 Christian D 2012-01-25 16:30:45 EST
Your 3.2.1-4.1.fc16.x86_64 kernel solves the issue for me. No more BUGs and all devices are working properly.
Thank you
Comment 16 Jimmy Dorff 2012-01-25 16:34:47 EST
So far, no error when using 3.2.1-4.1.fc16.x86_64.debug
Comment 17 Josh Boyer 2012-01-25 22:07:27 EST
Thanks to both of you for testing.  I've committed Stanislaw's patch to Fedora git and it will be included in the next kernel submitted to updates-testing.
Comment 18 collura 2012-01-26 05:34:18 EST
Created attachment 557635 [details]
dmesg for kernel-3.2.1-3.fc16.x86_64 does have the 'scheduling while atomic' errors for various programs
Comment 19 collura 2012-01-26 05:36:27 EST
Created attachment 557636 [details]
dmesg for kernel-3.2.1-4.1.fc16.x86_64 fixes the 'scheduling while atomic' error for me as well thanks :')
Comment 20 Fedora Update System 2012-01-26 08:52:56 EST
kernel-3.2.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.2-1.fc16
Comment 21 Josh Boyer 2012-01-26 10:13:14 EST
*** Bug 784884 has been marked as a duplicate of this bug. ***
Comment 22 Iván Jiménez 2012-01-26 14:49:37 EST
just turned it on

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 23 Fedora Update System 2012-01-26 17:54:46 EST
Package kernel-3.2.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.2.2-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0949/kernel-3.2.2-1.fc16
then log in and leave karma (feedback).
Comment 24 Henrik Nordström 2012-01-27 06:40:07 EST
*** Bug 785121 has been marked as a duplicate of this bug. ***
Comment 25 jorge 2012-01-27 12:50:35 EST
I only have been working and it's happening, i updated yesterday.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 26 collura 2012-01-27 15:29:22 EST
Created attachment 557942 [details]
dmesg for kernel-3.2.2-1.fc16.x86_64 seems 'scheduling while atomic' error still fixed :')
Comment 27 Josh Boyer 2012-01-27 18:16:55 EST
*** Bug 785311 has been marked as a duplicate of this bug. ***
Comment 28 Jae Kim 2012-01-27 18:17:22 EST
Updated system to the latest kernel along with other updates, after rebooting the system, this message started to appear

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 29 Fedora Update System 2012-01-27 22:33:13 EST
kernel-3.2.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 30 Josh Boyer 2012-01-28 08:15:03 EST
*** Bug 784362 has been marked as a duplicate of this bug. ***
Comment 31 Josh Boyer 2012-01-30 13:19:59 EST
*** Bug 784491 has been marked as a duplicate of this bug. ***
Comment 32 Josh Boyer 2012-01-30 13:20:07 EST
*** Bug 784606 has been marked as a duplicate of this bug. ***
Comment 33 Josh Boyer 2012-01-30 13:20:20 EST
*** Bug 784681 has been marked as a duplicate of this bug. ***
Comment 34 Josh Boyer 2012-01-30 13:20:32 EST
*** Bug 784755 has been marked as a duplicate of this bug. ***
Comment 35 Josh Boyer 2012-01-30 13:21:07 EST
*** Bug 784808 has been marked as a duplicate of this bug. ***
Comment 36 Josh Boyer 2012-01-30 15:35:24 EST
*** Bug 784404 has been marked as a duplicate of this bug. ***
Comment 37 Josh Boyer 2012-02-02 08:57:42 EST
*** Bug 786658 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.