Bug 784532 - control-center or gnome-settings-deamon seems to break settings-screen- brightness slider control so disappears for kernels > kernel-3.1.9-1.fc16.x86_64
control-center or gnome-settings-deamon seems to break settings-screen- brigh...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
16
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-25 04:37 EST by collura
Modified: 2013-02-13 07:23 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 07:23:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
var log messages for only kernel-3.2.1-3 with kernel-debug installed (418.70 KB, application/octet-stream)
2012-01-25 04:37 EST, collura
no flags Details
var log messages for various kernels including the 3.2.0-2.fc17 (1.30 MB, text/plain)
2012-01-25 04:40 EST, collura
no flags Details
smolt data (3.08 KB, text/plain)
2012-01-25 04:51 EST, collura
no flags Details
dmesg for kernel-3.1.9-1.fc16.x86_64 (67.54 KB, text/plain)
2012-01-26 05:15 EST, collura
no flags Details
dmesg for kernel-3.2.1-4.1.fc16.x86_64 (66.75 KB, text/plain)
2012-01-26 05:21 EST, collura
no flags Details
dmesg for kernel-3.2.2-1.fc16.x86_64 (66.67 KB, text/plain)
2012-01-27 15:23 EST, collura
no flags Details
var log messages for kernel-3.2.2-1.fc16.x86_64 disappearing brightness slider (138.43 KB, text/plain)
2012-01-27 16:33 EST, collura
no flags Details
settings-screen-brightness slider not fixed yet (68.37 KB, text/plain)
2012-02-04 03:17 EST, collura
no flags Details

  None (edit)
Description collura 2012-01-25 04:37:44 EST
Created attachment 557413 [details]
var log messages for only kernel-3.2.1-3 with kernel-debug installed

Description of problem:

  kernel-3.2.1-3.fc16.x86_64 seems to break the brightness slider
  (presumably by not identifying some hardware? 
    thus the max default brightness?)

  brightness control slider not there in its location 
  in the settings-screen-brightness gui

  brightness control works but is forgetful after reboot(another bug)
    kernel-3.1.9-1.fc16.x86_64

  brightness control briefly shows on settings-screen-brightness 
   but then disappears so cant set and brightness defaults to max
    kernel-3.2.1-3.fc16.x86_64
    kernel-3.2.0-2.fc17.x86_64


Version-Release number of selected component (if applicable):

  kernel-3.2.1-3.fc16.x86_64 breaks it

How reproducible:

  always

Steps to Reproduce:
1. boot to respective kernel
2. go to settings-screen-brightness to try to set brightness with slider
3. brightness slider is/isnt there depending on kernel 
4. 
  
Actual results:

  cant set brightness with slider 
    ( different bug: defaults to max after reboot )

Expected results:

  slider shows up and could be used to set brightness after forgetful reboot

Additional info:

  'echo $desired_1_to_10_value > /sys/class/backlight/acpi_video0/brightness' workaround still works but still havent dug out working gconf gsettings/dconf keys workaround to set
Comment 1 collura 2012-01-25 04:40:53 EST
Created attachment 557416 [details]
var log messages for various kernels including the 3.2.0-2.fc17

line 0001 was from kernel-3.1.9-1.fc16.x86_64 no kernel-debug
line 1330 was from kernel-3.2.1-3.fc16.x86_64 no kernel-debug
line 2648 was from kernel-3.2.0-2.fc17.x86_64 with kernel-debug
Comment 2 collura 2012-01-25 04:51:13 EST
Created attachment 557418 [details]
smolt data
Comment 3 collura 2012-01-26 05:15:24 EST
Created attachment 557632 [details]
dmesg for kernel-3.1.9-1.fc16.x86_64

kernel-3.1.9-1.fc16.x86_64 : brightness slider works (but is forgetful, another bug)
Comment 4 collura 2012-01-26 05:21:35 EST
Created attachment 557633 [details]
dmesg for kernel-3.2.1-4.1.fc16.x86_64

kernel-3.2.1-4.1.fc16.x86_64 has disappearing slider
Comment 5 collura 2012-01-27 15:23:54 EST
Created attachment 557940 [details]
dmesg for kernel-3.2.2-1.fc16.x86_64

kernel-3.2.2-1.fc16.x86_64 has disappearing slider
Comment 6 collura 2012-01-27 16:33:04 EST
Created attachment 557957 [details]
var log messages for kernel-3.2.2-1.fc16.x86_64 disappearing brightness slider
Comment 7 collura 2012-02-04 03:17:18 EST
Created attachment 559398 [details]
settings-screen-brightness slider not fixed yet
Comment 8 collura 2012-02-04 03:20:03 EST
kernel-3.2.3-2.fc16.x86_64 doesnt fix the disappearing brightness bar
Comment 9 collura 2012-02-10 16:29:09 EST
brightness slider still broek as of kernel-3.2.5-3.fc16.x86_64
Comment 10 collura 2012-02-14 16:35:53 EST
kernel-3.2.6-3.fc16.x86_64 is no fix for slider of brightness
Comment 11 collura 2012-02-22 13:53:05 EST
kernel-3.2.7-1.fc16.x86_64 avails no slider
Comment 12 collura 2012-03-01 18:35:47 EST
kernel-3.2.8-3.fc16.x86_64 also has disappearing slider
Comment 13 collura 2012-03-07 01:33:52 EST
kernel-3.2.9-1.fc16.x86_64 slider disappear
Comment 14 collura 2012-03-07 01:49:12 EST
kernel-3.2.9-2.fc16.x86_64 disappearance of slider
Comment 15 collura 2012-03-09 03:14:38 EST
hmm 

kernel-3.1.9-1.fc16.x86_64 still has funtioning brightness slider 
but as stated above various other kernels give broken brightness slider

fedora-17-alpha-gnome livecd had functioning brightness slider
fedora-17-alpha-gnome initial install had functioning brightness slider

but

ran ~288 updates of f17-alpha from updates/updates-testing broke the slider

'yum history rollback' failed so wasnt able to unbreak it to find the problem package at the time

was able to downgrad a few of the packages that seemed worth a try 
but wasnt able to un-break the slider.

was able to downgrade from the updated kernel 
  kernel-3.3.0-0.rc6.git0.2.fc17.x86_64
to the former kernel 
  kernel-3.3.0-0.rc3.git7.2.fc17.x86_64
but that did not fix the slider.

looking at that i would say that the downgrade of kernel would say that its not the kernel that was the problem and so would close this bug as wrong except for that there is the repeatability of the working kernel-3.1.9-1.fc16.x86_64 
which i can still reliably reproduce as the last kernel to have a functioning slider on an fully updated system fc16.

so then maybe its a combination of kernel and some other package(s) that cause the slider to break?  until i figure the other package(s) i will leave this bug open.

ps: for what its worth the fc17-alpha is looking pretty great for an alpha :')
Comment 16 collura 2012-03-15 20:22:57 EDT
kernel-3.3.0-0.rc7.git0.3.fc17.x86_64 no brightness slider
Comment 17 collura 2012-03-18 20:04:39 EDT
kernel-3.2.10-3.fc16.x86_64 no slider
Comment 18 collura 2012-03-20 15:40:34 EDT
kernel-3.3.0-1.fc17.x86_64 disappearing slider
Comment 19 collura 2012-03-22 15:17:28 EDT
kernel-3.3.0-4.fc16.x86_64 slider still disappears.  phwoosh.
Comment 20 collura 2012-03-23 23:47:17 EDT
fc17alpha updates-testing just got gnome-settings-daemon/gnome-control-center/linux-firmware updates.  

the gnome-settings-daemon seems to be the fix for the slider.  need to read a bit more but think going to repoint package to gnome-settings-daemon. :')

a gnome-settings-daemon fix seems to agree with this snippet from .xsession-errors :

"(gnome-settings-daemon:1684): GLib-GIO-CRITICAL **: g_dbus_method_invocation_return_gerror: assertion `error != NUL
L' failed

(gnome-settings-daemon:1684): GLib-CRITICAL **: g_error_free: assertion `error != NULL' failed

(gnome-control-center:2088): screen-cc-panel-WARNING **: Error getting brightness: Timeout was reached
"

i had taken the gnome-settings/gnome-control-center errors as effect instead of cause since the kernel-3.1.9-1.fc16.x86_64 gives working brightness slider while later fc16 kernels didnt.  similar for the initial install from fc17alpha
(livecd and install) giving functioning brightness slider while the slider breaks after run the post install fc17 updates though was never able to track down which of the fc17alpha-updates caused the problem.

more later.
Comment 21 collura 2012-03-25 23:40:20 EDT
based on comment#20 not sure if problem related 
to kernel or 
to gnome-settings-daemon/gnome-control-center/linux-firmware
or glib or dbus or gnome-power-manager-backlight 
or something else so not repointing to some other package yet

0) **gnome-settings-daemon update worked for fc17alpha-gnome: 

the disappearing slider seems to be fixed by

  gnome-settings-daemon-3.3.92-1.fc17.x86_64

1) however for fc16 there was no luck in fixing the disappearing slider 
for fc16 kernels > kernel-3.1.9-1.fc16.x86_64 

though kernel-3.1.9-1.fc16.x86_64 
still seems to fix things on fc16.

had tried 
  control-center-1:3.2.1-2.fc16.x86_64 instead of 
  control-center-1:3.2.2-1.fc16.x86_64 
or downgrading the 
  gnome-settings-daemon-3.2.2-1.fc16.x86_64 to 
  gnome-settings-daemon-3.2.1-3.fc16.x86_64, 
or upgrading to
  gnome-settings-daemon-3.2.2-2.fc16.x86_64 from koji
maybe didnt rollback the gnome-settings-daemon far enough?

2) will try dbus-glib and glib and dbus on fc16 
as noted in comment#20 above the .xsession-errors error 
for gnome-settings-daemon about 

  'GLib-GIO-CRITICAL **: g_dbus_method_invocation_return_gerror' 

since that is the only error message i can see (as noted in comment#20 above)
at the moment

3) at least for fc17alpha-gnome the gnome-settings-daemon-3.3.92-1.fc17.x86_64 seems to fix the issue.
Comment 22 collura 2012-03-26 03:22:28 EDT
fyi, got the following core dump of control center on fc16-gnome:
  https://bugzilla.redhat.com/show_bug.cgi?id=806730
when ran 'control-center --g-fatal-warnings' from commandline 
when click on the 'screen' icon of the settings gui.

(hmm note that for fc17 gnome-settings-daemon apparent fix listed in comment#21 
that the upgrade/downgrade of gnome-settings-daemon that fixed/broke the brightness slider was done with all other packages including gnome-control-center being fully up to date.)
Comment 23 collura 2012-03-26 07:15:14 EDT
ok the plot thickens for a control-center vs gnome-settings-daemon 
cause in fc16.

from skimming control-center-3.2.1-2.fc16 sourcecode 
for the screen panel init routine
it seems like the init might reference 
a non-existant gsettings dconf key 
  'org.gnome.SettingsDaemon.Power.Screen' 
which might read as a timeout?

would like to think creation of the missing key 
might be why a gnome-settings-daemon update seemed to help in fc17
but looks like the fc17 control-center-3.3.92-1.fc17 display panel init 
had like a nifty major rewrite so not sure what is up with it as 
still skimming through function definitions.

lol, so maybe the gnome-settings-daemon errors in .xsession-errors are not related to the fc17 fix even though the gnome-settings-daemon seems to be tied to the fc17 fix.
Comment 24 collura 2012-05-06 00:51:25 EDT
0) the slider for fc16 
still disappears as of 

 kernel-3.3.4-3.fc16.x86_64
 control-center-1:3.2.2-1.fc16.x86_64
 gnome-settings-daemon-3.2.3-1.fc16.x86_64

 (except for an fc16 with 
    kernel-3.1.9-1.fc16.x86_64
  which gives working slider)

1) the current fc17beta still 
has a slider that is working fine

  kernel-3.3.4-3.fc17.x86_64
  control-center-3.4.1-1.fc17.x86_64
  gnome-settings-daemon-3.3.4-1.fc17.x86_64
Comment 25 collura 2012-05-08 03:28:23 EDT
from comment#24 

  slider broken with kernel-3.3.4-3.fc16.x86_64
  slider works  with kernel-3.3.4-3.fc17.x86_64

lol so its time to shift blame away from kernel 
(even though for the kernel-3.1.9-1.fc16.x86_64
fixes things for fc16).

modifying title 
  from 'kernel' 
  to 'control-center or gnome-settings-daemon' 

changing package 
  from 'kernel' 
  to 'gnome-settings-daemon' for now 

changing version to fc16 
as fc17beta currently works (comment#21).
Comment 26 collura 2012-07-27 00:16:19 EDT
fc16 slider still disappears/broken with:

  kernel-3.4.4-4.fc16.x86_64
  control-center-3.2.3-1.fc16.x86_64
  gnome-settings-daemon-3.2.3-1.fc16.x86_64

fc17 still works (but brightness still forgetful)
Comment 27 Fedora End Of Life 2013-01-16 07:12:33 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 28 Fedora End Of Life 2013-02-13 07:23:55 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.