This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 784546 - [VDSM]- VDSM should allow the useage of ETH interface's IPADDR for VLAN/Bridge
[VDSM]- VDSM should allow the useage of ETH interface's IPADDR for VLAN/Bridge
Status: CLOSED DUPLICATE of bug 787709
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Dan Kenigsberg
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-25 05:31 EST by zvi
Modified: 2016-04-18 02:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 17:12:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
eth_with_ip (936.21 KB, application/x-gzip)
2012-01-25 05:31 EST, zvi
no flags Details

  None (edit)
Description zvi 2012-01-25 05:31:35 EST
Created attachment 557423 [details]
eth_with_ip

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


When attempting to add a VLAN to an HOST's ETH, with already configured IP address - It will not accept the original IP address of the interface for that VLAN.
VDSM should know that after adding a Brdige (LN), the original IP of the interface will be lost, and therefore this IPADDR can be used.


Steps to Reproduce:
1.via webadmin try to attach a vlan to an eth with already configured IPADDR
2.
3.
  
Actual results:


Expected results:


Additional info:
Trying to create a vlan on eth 3 with IPADDR of eth3 (10.20.20.200) fails:


Thread-35982::DEBUG::2012-01-25 11:59:15,588::clientIF::76::vds::(wrapper) [10.35.97.70]::call addNetwork with ('164', '164', '', ['eth3'], {'STP': 'no', 'NETMASK': '255.255.255.0', 'IPADDR': '10.20.20.200'}) {}
.
.
.
Thread-35982::ERROR::2012-01-25 11:59:15,632::clientIF::1125::vds::(addNetwork) IP address is already in use



If a different IPADDR will be chosen (10.20.20.222) the bridge for that VLAN will be created and the original IPADDR (10.20.20.200) will not be in use in the HOST.
Comment 1 Dan Kenigsberg 2012-01-25 06:53:30 EST
Correct, when validating the IP address, we should discount addresses that are to be deleted.
Comment 4 Dan Kenigsberg 2012-04-10 17:12:57 EDT

*** This bug has been marked as a duplicate of bug 787709 ***

Note You need to log in before you can comment on or make changes to this bug.