Bug 78456 - Upgrade to Evolution 1.2 and process of POP3 mail receive is slow.
Upgrade to Evolution 1.2 and process of POP3 mail receive is slow.
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-23 03:02 EST by Ivo Sarak
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-09 22:06:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-11-23 03:02:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After upgrade from Evolution 1.0.8 (evolution-1.0.8-10.rpm) to Evolution 1.2
(evolution-1.2.0-2.rpm), it takes "for ages" to receive any new mail.


I suspect there is a bug in Evolution mail checking system and it will
download all mails (not only headers) from mail account before it will
download new mails.

It is annoying, if to say mildly, but actually it will render Evolution quite
useless...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download Evolution package from RawHide;
2.Upgrade Evolution package;
3.Run Evolution;
4.Check mail;

Actual Results:  Progressbar of "Retrieve POP summary" goes to end with decent
speed, but then it will sit there. There is a constant 40KBytes/s download
stream for about 10 minutes and then it will download newer mails if available
(with rate about 100KBytes/s).

Also, during the whole usage of Evolution, statusbar is constantly stating
"Fetching Mail (...)".

Expected Results:  After the completion of "Retrieve POP summary" it should
start to download new mails immediately.

Additional info:

I have set "Leave messages on server" and there is about 6000 of them.

Also, when to exit Evolution it will popup a window "Evolution is now
exiting...", but this window will never (at least in sense of "reasonable" time)
leave the scene and must be killed to be gone.

Is there something I may do about it or is this normal behaviour?
Has these problems caused by upgrade by itself?
(These big projects tend to break during the upgrade, one good example is
OpenOffice.org.)

(Evolution 1.0.8 didn't have these problems.)
Comment 1 Ivo Sarak 2002-11-25 02:21:26 EST
Upgrade to evolution-1.2.0-3 did not resolved the problem.
Comment 2 Jeremy Katz 2002-12-13 11:06:52 EST
This sounds correct to me.  With POP, you download the whole messages, not just
download the headers and do on-demand downloading of messages.  To do the
latter, you use IMAP, not POP.
Comment 3 Ivo Sarak 2002-12-14 17:44:12 EST
How is it possible that with Evolution 1.0.8 this kind of POP3 mail fetching
worked fine?
Comment 4 Ivo Sarak 2002-12-26 04:56:25 EST
OK, if it is not a bug then clearly there is a need to indicate how much message
headers must be scanned and where it is at the moment. Currently it just will
sit there and it is hard to predict when it will stop the scanning of the
headers and will start downloading the messages.
Comment 5 Jeremy Katz 2003-02-09 22:06:28 EST
1.2.x is considered to be "more correct" as far as how it does things.  If your
pop server doesn't appear to provide the capabilities, it falls back to the
slower method.

Note You need to log in before you can comment on or make changes to this bug.