Bug 784663 - subscription_request_msg gets corrupted after changing request msg in GUI
Summary: subscription_request_msg gets corrupted after changing request msg in GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gajim
Version: 16
Hardware: All
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Schmidt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-25 18:03 UTC by Victor Ashik
Modified: 2012-03-26 17:56 UTC (History)
1 user (show)

Fixed In Version: gajim-0.15-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-26 03:58:56 UTC
Type: ---


Attachments (Terms of Use)

Description Victor Ashik 2012-01-25 18:03:13 UTC
Description of problem:

Setting custom multiline authorization request corrupts config and prevents gajim to start until config fixed.

Version-Release number of selected component (if applicable):



How reproducible:

Always.

Steps to Reproduce:

1. Set custom two lines request message in GUI. This causes gajim to write those to lines into .config/gajim/config as is:

accounts.yandex-team.ru.subscription_request_msg = Hi!
Please let me to add you...
2. Terminate gajim
3. Try to start gajim
  
Actual results:

gajim fails to star with error messages:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)
creating /home/vashik/.cache/gajim directory
creating /home/vashik/.cache/gajim/vcards directory
creating /home/vashik/.cache/gajim/avatars directory
creating logs database
creating cache database
Traceback (most recent call last):
File "gajim.py", line 429, in
interface = Interface()
File "/usr/share/gajim/src/gui_interface.py", line 3356, in __init__
cfg_was_read = parser.read()
File "/usr/share/gajim/src/common/optparser.py", line 66, in read
optname, key, subname, value = regex.match(line).groups()
AttributeError: 'NoneType' object has no attribute 

Expected results:

gajim to start normally

Additional info:

It is fixed in Debian: 

http://www.mail-archive.com/debian-bugs-closed@lists.debian.org/msg336397.html

Comment 1 Michal Schmidt 2012-01-26 09:41:50 UTC
It seems it's already fixed in the beta releases of 0.15. Try the gajim package from updates-testing.

Comment 2 Fedora Update System 2012-01-27 11:29:36 UTC
gajim-0.15-0.4.beta4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-15286/gajim-0.15-0.4.beta4.fc16

Comment 3 Victor Ashik 2012-01-27 14:50:59 UTC
(In reply to comment #1)
> It seems it's already fixed in the beta releases of 0.15. Try the gajim package
> from updates-testing.

I set up gajim-0.15-0.4.beta4.fc16 by issuing command:

sudo yum update --enablerepo=updates-testing gajim

It seems that the bug is fixed.
But new version frequently popping up message box "A programming error has been detected" with explanation text:
 
Traceback (most recent call last):
  File "/usr/share/gajim/src/roster_window.py", line 1658, in _compareIters
    name2 = model[iter2][C_JID].decode('utf-8')
AttributeError: 'NoneType' object has no attribute 'decode'

Comment 4 Michal Schmidt 2012-01-27 14:56:40 UTC
Looks like the bug reported in the upstream bugtracker here:
https://trac.gajim.org/ticket/7062
It should have been fixed in beta4. Could you talk directly to upstream about this?

Comment 5 Michal Schmidt 2012-01-27 14:58:16 UTC
But first, could you double-check what version you have installed?:
rpm -q gajim

According to Bodhi, the beta4 package has not reached updates-testing yet.

Comment 6 Victor Ashik 2012-01-27 15:05:45 UTC
(In reply to comment #5)
> But first, could you double-check what version you have installed?:
> rpm -q gajim
> 
> According to Bodhi, the beta4 package has not reached updates-testing yet.

Sorry, I lied. I have gajim-0.15-0.2.beta3.fc16.noarch

Comment 7 Fedora Update System 2012-01-28 03:29:03 UTC
Package gajim-0.15-0.4.beta4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gajim-0.15-0.4.beta4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15286/gajim-0.15-0.4.beta4.fc16
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-03-21 02:36:29 UTC
Package gajim-0.15-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gajim-0.15-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15286/gajim-0.15-1.fc16
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-03-26 03:58:56 UTC
gajim-0.15-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2012-03-26 17:56:29 UTC
gajim-0.15-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.