Bug 784699 - JON 3.0.1 RC#1: Error with doc example 2.9, "-s" and "-t" command line options
JON 3.0.1 RC#1: Error with doc example 2.9, "-s" and "-t" command line options
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: CLI (Show other bugs)
3.0.1
Unspecified Unspecified
high Severity high (vote)
: ---
: JON 3.0.1
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-01-25 15:21 EST by Mike Foley
Modified: 2013-08-05 20:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-01 09:58:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2012-01-25 15:21:21 EST
Description of problem:  Error with doc example 2.9,  "-s" and "-t" command line options


Version-Release number of selected component (if applicable):


How reproducible: 100%


[mfoley@foleymonsterbox1 bin]$ ./rhq-cli.sh -u rhqadmin -p rhqadmin -s 192.168.0.2 -t 16163
RHQ - RHQ Enterprise Remote CLI 4.2.0.JON.3.0.1.GA
Login failed: Can not connect http client invoker. No route to host.
Usage: login username password [host port [transport]]
unconnected$ quit
Comment 1 Mike Foley 2012-01-30 11:26:00 EST
12/30/2012 BZ triage meeting mfoley, ccrouch, loleary, asantos
Comment 2 Ian Springer 2012-01-31 17:23:30 EST
Why are you using port 16163? That's the default Agent port. The CLI connects to the Server, so typically the port should be 7080.
Comment 3 Mike Foley 2012-02-01 06:20:10 EST
same behavior on 7080

[mfoley@foleymonsterbox1 bin]$ ./rhq-cli.sh -u rhqadmin -p rhqadmin -s 192.168.0.2 -t 7080
RHQ - RHQ Enterprise Remote CLI 4.2.0.JON.3.0.1.GA
Login failed: Can not connect http client invoker. No route to host.
Usage: login username password [host port [transport]]
unconnected$
Comment 4 Ian Springer 2012-02-01 09:22:42 EST
It works for me (using master):

[ips@jetengine bin]$ ./rhq-cli.sh -u rhqadmin -p rhqadmin -s 127.0.0.1 -t 7080
Listening for transport dt_socket at address: 9787
RHQ Enterprise Remote CLI 4.3.0-SNAPSHOT
Remote server version is: 4.3.0-SNAPSHOT (47aff46)
Login successful
rhqadmin@127.0.0.1:7080$ 


Are you sure 192.168.0.2 is the correct IP address for the Server?
Comment 5 Mike Foley 2012-02-01 09:58:45 EST
[mfoley@foleymonsterbox1 bin]$ ./rhq-cli.sh -u rhqadmin -p rhqadmin -s 127.0.0.1 -t 7080
RHQ - RHQ Enterprise Remote CLI 4.2.0.JON.3.0.1.GA
Remote server version is: 3.0.1.GA (784c8ce:5cde182)
Login successful
rhqadmin@127.0.0.1:7080$

Note You need to log in before you can comment on or make changes to this bug.