Bug 784704 - Selecting 'subscriptions' on a system that has no subscriptions results in an error
Selecting 'subscriptions' on a system that has no subscriptions results in an...
Status: CLOSED DUPLICATE of bug 784679
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Jordan OMara
Eric Sammons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-25 15:41 EST by Jordan OMara
Modified: 2014-11-09 17:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-26 09:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan OMara 2012-01-25 15:41:30 EST
Go to systems overview 
Select a system that is not subscribed to anything
Select "Subscriptions"

Result:
You have a nil object when you didn't expect it! You might have expected an instance of Array. The error occurred while evaluating nil.[]

Not sure if expected is to just say "Not subscribed to anything" or if it should let you choose things to subscribe to, but this is probably not what you would expect :)
Comment 1 Jordan OMara 2012-01-26 09:19:55 EST

*** This bug has been marked as a duplicate of bug 784679 ***

Note You need to log in before you can comment on or make changes to this bug.