This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 784801 - ICE in extract_insn, at recog.c:2109
ICE in extract_insn, at recog.c:2109
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
15
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-01-26 04:38 EST by Dan Horák
Modified: 2012-01-31 05:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-31 05:49:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2012-01-26 04:38:12 EST
Build of hercules-3.07-2.fc15 fails on armv7hl (gcc-4.6.1-9.fc15.0.arm5.armv7hl) with

...
esame.c: In function 'z900_load_long_byte_register':
esame.c:8001:1: error: unrecognizable insn:
(insn 25 24 26 2 (set (subreg:SI (reg:DI 153 [ regs_7(D)->gr[r2_6].F.L.H.L.B.L ]) 0)
        (sign_extend:SI (mem/s:QI (plus:SI (mult:SI (reg:SI 152)
                        (const_int 8 [0x8]))
                    (reg/v/f:SI 144 [ regs ])) [0 regs_7(D)->gr[r2_6].F.L.H.L.B.L+0 S1 A64]))) esame.c:7999 -1
     (nil))
esame.c:8001:1: internal compiler error: in extract_insn, at recog.c:2109

Jakub, please take this report rather as placeholder for other people seeing the same error, because
- I don't have a armv7 system ready to provide the preprocessed sources or other outputs
- it could be already fixed in gcc 4.7 (I saw similar reports in gcc bugzilla)
- it's being built with a private gcc version not the Fedora one
Comment 1 Dan Horák 2012-01-26 04:48:02 EST
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=279646 is the build
Comment 2 Jakub Jelinek 2012-01-31 05:49:56 EST
Builds just fine in f17, http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=292256
WONTFIX for GCC 4.6/ARM support.

Note You need to log in before you can comment on or make changes to this bug.