Bug 784825 - Issues related provisioning of a VGuest to VHost that has no Provisioning Entitlement
Issues related provisioning of a VGuest to VHost that has no Provisioning Ent...
Status: CLOSED DUPLICATE of bug 702330
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2012-01-26 06:17 EST by Dimitar Yordanov
Modified: 2012-03-08 04:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-26 06:40:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshout 1 (131.15 KB, image/png)
2012-01-26 06:18 EST, Dimitar Yordanov
no flags Details
Screenshot 2 (116.06 KB, image/png)
2012-01-26 06:20 EST, Dimitar Yordanov
no flags Details
Screenshot 3 (86.98 KB, image/png)
2012-01-26 06:21 EST, Dimitar Yordanov
no flags Details

  None (edit)
Description Dimitar Yordanov 2012-01-26 06:17:33 EST
Description of problem:

The implementation of Virtual Hosts provisioning via WebUI does not take in account that the Virtual Host could not have Provisioning Entitlement.

Version-Release number of selected component (if applicable):
spacewalk-java-1.2.39-112.el5sat

How reproducible:
100%

Steps to Reproduce:
1. Register a VHost KVM system to Satellite
2. Set the following entitlement
    Management
    Virtualization Platform

NB: Do not set Provisioning Entitlement.
  
3. Create Kickstart for KVM Guest
4. Systems -> VHost -> Virtualization -> Provisioning  
5. Fill all required fields, mark "Do not use an RHN Satellite Proxy"  and press "Shedule  Kickstart and Finish" (See Screenshout 1)
6. You are redirected to "Session Status" Tab (See ScreenShout 2 )
7. Try to get to Tab labeled as "Shedule" 
   "Permission Error" (See ScreenShout 3)
8. System -> VHost -> Virtualization -> Provisioing ...
   
  
Actual results:
"Session Status"  Tab is not available at any side.

Expected results:

No "Permission Error"
"Session Status" Tab  is available throughout the whole provisioning process.


Additional info:
Comment 1 Dimitar Yordanov 2012-01-26 06:18:12 EST
Created attachment 557640 [details]
Screenshout 1
Comment 2 Dimitar Yordanov 2012-01-26 06:20:18 EST
Created attachment 557641 [details]
Screenshot 2
Comment 3 Dimitar Yordanov 2012-01-26 06:21:23 EST
Created attachment 557642 [details]
Screenshot 3
Comment 4 Šimon Lukašík 2012-01-26 06:36:18 EST
It would be helpful to provide the url per each screen shot.
Comment 5 Šimon Lukašík 2012-01-26 06:40:36 EST

*** This bug has been marked as a duplicate of bug 702330 ***

Note You need to log in before you can comment on or make changes to this bug.