Bug 784870 - SSSD fails during autodetection of search bases for new LDAP features
SSSD fails during autodetection of search bases for new LDAP features
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.2
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On: 773706 784984
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-26 09:22 EST by Dmitri Pal
Modified: 2013-05-28 16:42 EDT (History)
10 users (show)

See Also:
Fixed In Version: sssd-1.8.0-23.el6
Doc Type: Bug Fix
Doc Text:
No documentation required
Story Points: ---
Clone Of: 773706
Environment:
Last Closed: 2012-06-20 07:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-01-26 09:22:26 EST
+++ This bug was initially created as a clone of Bug #773706 +++

Created attachment 552449 [details]
sssd logs

Description of problem:

With sssd-1.7.0-1.fc16.i686 I'm getting expired kerberos tickets on login.

It appears to not setup the ldap server properly.

--- Additional comment from sgallagh@redhat.com on 2012-01-12 13:23:21 EST ---

The issue here is that the LDAP server in question has multiple entries for 'namingContexts' in the rootDSE, but does not have a 'defaultNamingContext' attribute to identify which is the primary.

However, this should only be necessary if there are ldap_*_search_base attributes that were not populated by the config file. In this particular user's case, the ldap_search_base option is in use, which should be sufficient.

So the correct fix here is to identify why we're caring about the inability to identify the default naming context, since we aren't using it for anything.

Thanks for the bug report.

--- Additional comment from sgallagh@redhat.com on 2012-01-26 07:50:51 EST ---

Upstream ticket:
https://fedorahosted.org/sssd/ticket/1152
Comment 1 Dmitri Pal 2012-01-26 09:24:33 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1152
Comment 2 Dmitri Pal 2012-04-19 13:31:07 EDT
It is already in. We just missed it in filing errata.
Comment 6 Jenny Galipeau 2012-05-11 13:13:17 EDT
need steps to verify this issue
Comment 7 Amith 2012-05-30 05:43:30 EDT
Verified on sssd-1.8.0-32.el6.
This bug has been verified sanity only and no related regressions detected.
Comment 8 Stephen Gallagher 2012-06-12 09:42:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation required
Comment 10 errata-xmlrpc 2012-06-20 07:51:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.