This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 784909 - rpc.gssd linking issue
rpc.gssd linking issue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Rock Lee
:
Depends On: 784908
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-26 10:57 EST by Simo Sorce
Modified: 2013-03-03 19:32 EST (History)
8 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-30.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 784908
Environment:
Last Closed: 2013-02-21 05:55:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2012-01-26 10:57:19 EST
+++ This bug was initially created as a clone of Bug #784908 +++

rpc.gssd is supposed to link against the libgssglue librray so that rpc.gssd becomes independent from the specific gssapi implementation.

Libgssglue uses the /etc/gssapi_mech.conf file to detemine what gssapi to dlopen() and use. By default it loads libgssapi_krb5.so which is provided by the MIT krb5 packages.

rpc.gssd do link agains libgssglue.so, unfortunately it also links against libgssapi_krb5.so

These 2 library export the same symbols so results are unpredictable if libgssglue is configured to use a different library.

rpc.gssd should not link against libgssapi_krb5 directly and let libgssglue.so load it dynamically at startup.
Comment 7 errata-xmlrpc 2013-02-21 05:55:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0468.html

Note You need to log in before you can comment on or make changes to this bug.