Bug 78499 - installer exception occured error as package installation begins
installer exception occured error as package installation begins
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-24 13:07 EST by Paul Pianta
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-24 13:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Pianta 2002-11-24 13:07:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020922

Description of problem:
installer exception occured error at the very beginning of package installation.
I am trying to install the minimal installation option on a really old toshiba
satellite 200cds laptop. everything goes smoothly until it looks like it is
ready to start to install packages and it gives the error dialog shown below.
(and the option to "save to floppy" is broken too :(  so i had to copy it by
hand (wah wah))
im thinking it could be a lack of memory - i have 40mb of ram and 800mb hard
drive partitioned into - /boot(50mb), swap(80mb), /(the rest)
i have successfully installed mandrake 7.2 on the machine without any problems
but i would really like to have redhat on it.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install from startup floppy which then boots cdrom
2.choose minimal installation package (actually any package config will produce
the same error)
3.get to the "installing packages" step and it will give an error dialog
	

Actual Results:  i got the error dialog

Expected Results:  install packages and finish the installation with a wonderful
fully functional router on my super old laptop.


Additional info:

this is the error message in the "Exception Occured" dialog:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
  self.intf.icw.nextClicked()
 File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetaDeletes(diskset)
 File "/usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
  lvm.vgactivate()
 File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath = 1)
 File "/usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
  childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory
Comment 1 Matt Wilson 2002-11-24 14:43:26 EST
you do not have enough ram to install via the GUI installer.  Use the text mode
installer by typing "text" at the boot:  prompt when you boot from your CD.

We have added a check for this to automatically go to text mode in the next version.

Note You need to log in before you can comment on or make changes to this bug.