Bug 784991 - JON 3.0.1 RC#1 Cannot reference classes succinctly without package names
JON 3.0.1 RC#1 Cannot reference classes succinctly without package names
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: CLI (Show other bugs)
3.0.1
Unspecified Unspecified
high Severity high (vote)
: ---
: JON 3.0.1
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-01-26 15:53 EST by Mike Foley
Modified: 2014-09-29 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-31 17:37:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2012-01-26 15:53:32 EST
Description of problem:  JON 3.0.1 RC#1  CLI Doc example 2.3 incorrectly states that some classes can be referenced succinctly without package names


Version-Release number of selected component (if applicable):  JON 3.01 RC1


How reproducible: 100%


Steps to Reproduce:
1.  read JON CLI doc example 2.3
2.  type recommended succinct version:  var criteria = new ResourceCritiera();

  
Actual results:  error


Expected results:  variable is set


Additional info:  CLI Doc example 2.3 states ....

For example, the class org.rhq.core.domain.critiera.ResourceCriteria is commonly used to query resources. The entire class path can be given when calling that class:
var criteria = new org.rhq.core.domain.criteria.ResourceCriteria();
var resource = new org.rhq.core.domain.resource.Resource();
Because the domain class is already imported, this can be more succinctly written as:
var criteria = new ResourceCritiera();
var resource = new Resource();
Comment 1 Mike Foley 2012-01-30 11:25:53 EST
12/30/2012 BZ triage meeting mfoley, ccrouch, loleary, asantos
Comment 3 Mike Foley 2014-09-29 10:38:53 EDT
.

Note You need to log in before you can comment on or make changes to this bug.