Bug 785215 - [RFE] allow schedd to claim multiple dynamic slots w/o negotiation cycle
[RFE] allow schedd to claim multiple dynamic slots w/o negotiation cycle
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
: FutureFeature, Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 11:40 EST by Timothy St. Clair
Modified: 2016-05-26 15:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 15:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Condor 2790 None None None Never
Condor 2802 None None None Never
Condor 2826 None None None Never

  None (edit)
Description Timothy St. Clair 2012-01-27 11:40:47 EST
Description of problem:
Filling a pool with dynamic slots can sometimes be a utilization issue if the jobs are short lived, b/c it will have to go through multiple rounds with the negotiator.  Fix will be to allow the schedd to claim multiple dynamic slots.
Comment 3 Timothy St. Clair 2012-02-22 16:37:18 EST
Punting back because we've found issue with the modification and concurrency limits.
Comment 4 Timothy St. Clair 2012-02-27 15:41:05 EST
In scoping issues it seems possible that we can adjust cc-limits to take slot weight into account.
Comment 5 Timothy St. Clair 2012-07-11 11:57:45 EDT
This exists in the 7.8 rebase, but there are still issues around cc-limits and we may want to open a separate ticket, and derive it from this one.
Comment 6 Timothy St. Clair 2012-07-13 11:53:02 EDT
Concurrency limits are respected, but still require multiple negotiation rounds provided that: 

NEGOTIATOR_USE_SLOT_WEIGHTS = True 

(which is defaulted to enable this feature.)
Comment 10 Mike McCune 2016-03-28 18:39:30 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 11 Anne-Louise Tangring 2016-05-26 15:12:07 EDT
MRG-G is in maintenance only and only customer escalations will be addressed from this point forward. This issue can be re-opened if a customer escalation associated with this issue occurs.

Note You need to log in before you can comment on or make changes to this bug.