Bug 78527 - RFE: add versioning in the result file for external maintenance 'hook'
RFE: add versioning in the result file for external maintenance 'hook'
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-kickstart (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-25 02:08 EST by R P Herrold
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 13:03:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample showing the proposed changes (853 bytes, text/plain)
2002-11-25 02:10 EST, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2002-11-25 02:08:06 EST
The present (v 2.3.3-3) result ks.cfg files are unversioned and undated.

May we have someting added along the lines of:

version: 2.3.3-3
date: 2002-11-25
vendor-local: accept and ignore arbitrary data

so that secondary management tools can identify, parse and manipulate these
files more intelligently, please.
Comment 1 R P Herrold 2002-11-25 02:10:38 EST
Created attachment 86268 [details]
sample showing the proposed changes
Comment 2 Brent Fox 2002-11-26 12:17:08 EST
The version and date fields are no problem, but I'm not sure about the
vendor-local part.  Are you wanting that exposed in the UI?
Comment 3 R P Herrold 2002-11-26 15:34:27 EST
Mebbe I should have split the RFE, because the version and date require no user
input handling, too.  /me bad.

My thought was to provide for a optional 'comment' type field, not hidden with a
leading # -- avoiding the leading # permits avoiding the ugliness in parsing
which chkconfig has to do.  Makes for simpler regex's and so forth

It seems to make sense either on a separate tab of its own, maybe called
'Comment', or at the bottom of the present Basic Configuration; _maybe_ it might
make sense on Post Configuration, but not really ...

My thought was to have a panel or section which says something like:

"You may optionally identify this configuration file with a comment which is
otherwise ignored by the Installer; some vendors may user this field to embed
local vendor configuration system management information."

and a one line text entry field.
Comment 4 Brent Fox 2002-12-16 13:03:17 EST
I see your point, but I'm going to say no to this one...mainly because the UI is
cluttered enough as it is.  I'm really trying to resist adding more widgets to
the UI.  Closing as 'wontfix'.

Note You need to log in before you can comment on or make changes to this bug.