Bug 785378 - option "GRUB_DEFAULT=saved" (/etc/default/grub) not honored
option "GRUB_DEFAULT=saved" (/etc/default/grub) not honored
Status: CLOSED DUPLICATE of bug 768106
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-28 08:11 EST by nicofo
Modified: 2012-04-09 16:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 16:00:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nicofo 2012-01-28 08:11:16 EST
Description of problem:
In /etc/default/grub, I have: 'GRUB_SAVEDEFAULT=true'
As a result in /boot/grub2/grub.cfg I have the line 'set default="${saved_entry}"'.
But after a kernel update (with yum), that line is modified to 'set default="0"'

Version-Release number of selected component (if applicable):
(Fedora 16 up to date)

How reproducible:
Yes

Steps to Reproduce:
1. When a kernel update is available, apply the update (this problem has happened several times with previous kernel updates)
2.
3.
  
Actual results:
In /boot/grub2/grub.cfg, the line:
 set default="${saved_entry}"     is modified to:
 set default="0"

Expected results:
Since 'GRUB_SAVEDEFAULT=true' is present in /etc/default/grub, 'set default="${saved_entry}"' should remain present in /boot/grub2/grub.cfg
Moreover, it is was happened when I regenerate /boot/grub2/grub.cfg with the command:
 grub2-config -o /boot/grub2/grub.cfg

Additional info:
File etc/default/grub:

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
# GRUB_TERMINAL="serial console"
# GRUB_SERIAL_COMMAND="serial --unit=0 --speed=9600"
GRUB_CMDLINE_LINUX="quiet rhgb \# video=SVIDEO-1:d"
GRUB_DISABLE_RECOVERY="true"
Comment 1 nicofo 2012-03-14 17:52:32 EDT
(sorry there is a mistake in the previous comment: I spoke about the option 'GRUB_SAVEDEFAULT=true' while it should be 'GRUB_DEFAULT=saved')

=> summary of the bug: 
'set default=0' is written in grub.cfg instead of 'set default="${saved_entry}"'
despite the fact that "GRUB_DEFAULT=saved" is in /etc/default/grub
Comment 2 Mads Kiilerich 2012-04-09 16:00:30 EDT

*** This bug has been marked as a duplicate of bug 768106 ***

Note You need to log in before you can comment on or make changes to this bug.