Bug 785417 - alsa: snd_hda_intel - no sound
alsa: snd_hda_intel - no sound
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-28 15:13 EST by Jan ONDREJ
Modified: 2012-03-22 03:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 03:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info (20.03 KB, text/plain)
2012-02-06 04:53 EST, Jan ONDREJ
no flags Details
Python script from hda-analyzer (1018 bytes, text/x-python)
2012-02-08 14:46 EST, anonyme
no flags Details
My hdafix script. (1018 bytes, text/x-python)
2012-03-16 15:59 EDT, Jan ONDREJ
no flags Details

  None (edit)
Description Jan ONDREJ 2012-01-28 15:13:58 EST
Description of problem:
On my laptop with Intel HDA soundcard there is no sound in any application. Alsamixer -c0 displays all sound settings OK, pulse is configured to play on this soundcard, application does not show any error.

Version-Release number of selected component (if applicable):
kernel-PAE-3.2.2-1.fc16.i686
kernel-PAE-3.2.1 too

Last working kernel:
kernel-PAE-3.1.10-2.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. boot 3.2.x kernel on my laptop ;-)
2. run speaker-test or any other sound application
  
Actual results:
no sound, no error

Expected results:
audio playback

Additional info:
Here is output from 3.2.2 kernel (grep -i alsa):

[   15.808827] ALSA sound/pci/hda/hda_codec.c:4951 autoconfig: line_outs=1 (0xb/0x0/0x0/0x0/0x0) type:hp
[   15.808838] ALSA sound/pci/hda/hda_codec.c:4955    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   15.808845] ALSA sound/pci/hda/hda_codec.c:4959    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   15.808851] ALSA sound/pci/hda/hda_codec.c:4960    mono: mono_out=0x0
[   15.808856] ALSA sound/pci/hda/hda_codec.c:4964    inputs:
[   15.808862] ALSA sound/pci/hda/hda_codec.c:4968  Mic=0xd
[   15.808867] ALSA sound/pci/hda/hda_codec.c:4968  CD=0x11
[   15.808872] ALSA sound/pci/hda/hda_codec.c:4970 
[   15.809641] ALSA sound/pci/hda/patch_realtek.c:1324 realtek: No valid SSID, checking pincfg 0x00000000 for NID 0x1d
[   15.809648] ALSA sound/pci/hda/patch_realtek.c:1407 realtek: Enable default setup for auto mode as fallback
[   20.681679] alsactl[769]: Found hardware: "HDA-Intel" "Realtek ALC861" "HDA:10ec0861,15840000,00100300 HDA:10573055,10573055,00100700" "0x1584" "0x9072"
[   20.685531] alsactl[769]: Hardware is initialized using a generic method
[   20.689268] alsactl[769]: /sbin/alsactl: set_control:1267: failed to obtain info for control #1 (No such file or directory)
[   20.694609] alsactl[769]: /sbin/alsactl: set_control:1267: failed to obtain info for control #2 (No such file or directory)
[   20.698439] alsactl[769]: /sbin/alsactl: set_control:1267: failed to obtain info for control #3 (No such file or directory)
[   20.702143] alsactl[769]: /sbin/alsactl: set_control:1267: failed to obtain info for control #4 (No such file or directory)
[   20.705805] alsactl[769]: /sbin/alsactl: set_control:1267: failed to obtain info for control #7 (No such file or directory)
...

Why there is speaker_outs=0 even if I have speakers on my laptop?
Btw., no sound on line-out too.
Comment 1 Jaroslav Kysela 2012-02-06 04:43:29 EST
Please, attach output from 'alsa-info.sh --no-upload' to this bug.
Comment 2 Jan ONDREJ 2012-02-06 04:53:34 EST
Created attachment 559582 [details]
alsa-info

Same problem with 3.2.3 kernel.
Comment 3 James 2012-02-06 11:12:54 EST
I have the same sound hardware and I also see the same issue.
Comment 4 Jaroslav Kysela 2012-02-06 11:39:36 EST
The BIOS didn't set the pincfg to some useable value. Blame the vendor.

Use hda-analyzer - http://www.alsa-project.org/main/index.php/HDA_Analyzer - to analyze the hardware connections and codec behaviour.

For ALC861 codec, we have some pinfixups for the node 0x0f - play with IN_EN and VREF_50. It controls the analog amplifier on some laptops.
Comment 5 Jan ONDREJ 2012-02-07 03:32:57 EST
(In reply to comment #4)
> The BIOS didn't set the pincfg to some useable value. Blame the vendor.
> 
> Use hda-analyzer - http://www.alsa-project.org/main/index.php/HDA_Analyzer - to
> analyze the hardware connections and codec behaviour.
> 
> For ALC861 codec, we have some pinfixups for the node 0x0f - play with IN_EN
> and VREF_50. It controls the analog amplifier on some laptops.

Thanks. Here are results:

IN_EN - no change, nothing happen
VREF - all values works well, except default HIZ, so VREF_50 plays sound nicely.

Can you fix this in later kernels?

Is there a workaround to set these parameter at boot until it will be fixed?
Comment 6 Jaroslav Kysela 2012-02-07 09:41:29 EST
Use 'Exp' (export) button to generate a python script with the changes.

The kernel patch will look like this:

--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -5610,6 +5610,7 @@ static const struct alc_fixup alc861_fixups[] = {
 
 static const struct snd_pci_quirk alc861_fixup_tbl[] = {
 	SND_PCI_QUIRK(0x1043, 0x1393, "ASUS A6Rp", PINFIX_ASUS_A6RP),
+	SND_PCI_QUIRK(0x1584, 0x0000, "Uniwill ECS M31EI", PINFIX_ASUS_A6RP),
 	SND_PCI_QUIRK(0x1584, 0x2b01, "Haier W18", PINFIX_ASUS_A6RP),
 	SND_PCI_QUIRK(0x1734, 0x10c7, "FSC Amilo Pi1505", PINFIX_FSC_AMILO_PI1505),
 	{}


or:

--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -5603,6 +5603,7 @@ static const struct alc_fixup alc861_fixups[] = {
 
 static const struct snd_pci_quirk alc861_fixup_tbl[] = {
 	SND_PCI_QUIRK_VENDOR(0x1043, "ASUS laptop", PINFIX_ASUS_A6RP),
+	SND_PCI_QUIRK(0x1584, 0x0000, "Uniwill ECS M31EI", PINFIX_ASUS_A6RP),	
 	SND_PCI_QUIRK(0x1584, 0x2b01, "Haier W18", PINFIX_ASUS_A6RP),
 	SND_PCI_QUIRK(0x1734, 0x10c7, "FSC Amilo Pi1505", PINFIX_FSC_AMILO_PI1505),
 	{}
Comment 7 anonyme 2012-02-08 14:46:24 EST
Created attachment 560369 [details]
Python script from hda-analyzer

This script fixes the problem on my machine
Comment 8 Josh Boyer 2012-03-16 15:40:21 EDT
Jan, did you run the script and use the Exp button as Jaroslav suggested?
Comment 9 Jan ONDREJ 2012-03-16 15:59:43 EDT
Created attachment 570692 [details]
My hdafix script.

Yes, sure. Here is my script. Still not fixed in 3.2.9-2.fc16.i686.PAE.
What else I can do to fix this upstream?
Comment 10 Jaroslav Kysela 2012-03-16 17:10:12 EDT
It is fixed in upstream, but the patch is not in the Fedora kernel:

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commitdiff;h=416846d2b31fc740ed9d5a5ec116964fb43c4358
Comment 11 Jan ONDREJ 2012-03-22 03:08:35 EDT
Looks like this is already fixed in 3.3.0-4.fc16.i686.PAE, which is now in Fedora stable updates.
Closing this bug. Thanks to all for help.

Note You need to log in before you can comment on or make changes to this bug.