This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 785516 - Regression: 3.2.2-1.fc16 breaks wlan/wifi on intel advanced-n 6230
Regression: 3.2.2-1.fc16 breaks wlan/wifi on intel advanced-n 6230
Status: CLOSED DUPLICATE of bug 785239
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-29 04:36 EST by Julian Sikorski
Modified: 2012-02-01 10:24 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-01 10:24:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (255.56 KB, text/plain)
2012-01-29 04:36 EST, Julian Sikorski
no flags Details

  None (edit)
Description Julian Sikorski 2012-01-29 04:36:41 EST
Created attachment 558135 [details]
/var/log/messages

Description of problem:
After an update to the 3.2.2-1.fc16 kernel, the wireless connection became pretty much unusable. It would keep working for a few minutes, after which, even though technically active, every attempt to go to any address would time out. Even to the router (192.168.1.1). Disconnecting and reconnecting from NM would bring it back up, but again, only for a very short period of time.
/var/log/messages is not that useful. The last line when connectivity is lost is:
iwlwifi 0000:04:00.0: Tx aggregation enabled on ra = c0:3f:0e:2d:f8:f0 tid = 0
I am attaching the full log of that boot session, it comprises of one disconnect/reconnect attempt and then connecting with wired network.

Version-Release number of selected component (if applicable):
3.2.2-1.fc16

How reproducible:
every time

Steps to Reproduce:
1. Obtain a machine with the said wlan card
2. Connect
3. Wait a few minutes
  
Actual results:
Connection stays up but nothing gets through

Expected results:
Connection is working as expected

Additional info:
Please let me know how I could obtain more useful logs
Comment 1 Björn Ruberg 2012-02-01 06:09:34 EST
Confirmed on thinkpad x220. Malfunctioning wifi with kernel 3.2.2-1 - works fine when going back to 3.2.1.

System log gives some information:
[many many lines like the following]
eb  1 11:23:32 x220 kernel: [ 6284.018796] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:24:30 x220 kernel: [ 6342.160988] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:26:43 x220 kernel: [ 6474.942111] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:27:31 x220 kernel: [ 6522.579491] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:28:19 x220 kernel: [ 6570.711529] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:29:06 x220 kernel: [ 6617.735926] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:30:08 x220 kernel: [ 6679.131020] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:32:37 x220 kernel: [ 6827.585632] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:34:45 x220 kernel: [ 6955.919837] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:35:10 x220 kernel: [ 6980.615719] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:35:44 x220 kernel: [ 7014.261284] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:37:42 x220 kernel: [ 7132.185101] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:38:53 x220 kernel: [ 7203.383898] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:39:19 x220 kernel: [ 7229.009733] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:39:48 x220 kernel: [ 7258.073619] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:40:53 x220 kernel: [ 7323.189844] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:41:58 x220 kernel: [ 7387.339748] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:43:14 x220 kernel: [ 7463.708904] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:43:56 x220 kernel: [ 7505.102583] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:44:11 x220 kernel: [ 7520.125221] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:45:01 x220 kernel: [ 7570.406466] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:45:36 x220 kernel: [ 7605.293815] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:45:51 x220 kernel: [ 7620.413210] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:47:31 x220 kernel: [ 7720.069540] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:48:07 x220 kernel: [ 7755.997950] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:54:25 x220 kernel: [ 8133.259734] cfg80211: Calling CRDA to update world regulatory domain                                                   
Feb  1 11:54:25 x220 NetworkManager[957]: <info> (wlan0): supplicant interface state: completed -> disconnected                                        
Feb  1 11:54:25 x220 NetworkManager[957]: NetworkManager[957]: <info> (wlan0): supplicant interface state: completed -> disconnected                   
Feb  1 11:54:25 x220 kernel: [ 8133.281305] cfg80211: World regulatory domain updated:                                                                 
Feb  1 11:54:25 x220 kernel: [ 8133.281312] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)                              
Feb  1 11:54:25 x220 kernel: [ 8133.281319] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)                                   
Feb  1 11:54:25 x220 kernel: [ 8133.281325] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)                                   
Feb  1 11:54:25 x220 kernel: [ 8133.281330] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)                                   
Feb  1 11:54:25 x220 kernel: [ 8133.281335] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)                                   
Feb  1 11:54:25 x220 kernel: [ 8133.281340] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)                                   
Feb  1 11:54:25 x220 kernel: [ 8133.281370] cfg80211: Calling CRDA for country: DE                                                                     
Feb  1 11:54:25 x220 kernel: [ 8133.289617] cfg80211: Regulatory domain changed to country: DE                                                         
Feb  1 11:54:25 x220 kernel: [ 8133.289623] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)                              
Feb  1 11:54:25 x220 kernel: [ 8133.289630] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)                                       
Feb  1 11:54:25 x220 kernel: [ 8133.289635] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)                                       
Feb  1 11:54:25 x220 kernel: [ 8133.289640] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)                                       
Feb  1 11:54:25 x220 kernel: [ 8133.289645] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)                                       
Feb  1 11:54:25 x220 NetworkManager[957]: <info> (wlan0): supplicant interface state: disconnected -> scanning                                         
Feb  1 11:54:25 x220 NetworkManager[957]: NetworkManager[957]: <info> (wlan0): supplicant interface state: disconnected -> scanning                    
Feb  1 11:54:28 x220 NetworkManager[957]: <info> (wlan0): supplicant interface state: scanning -> authenticating                                       
Feb  1 11:54:28 x220 NetworkManager[957]: NetworkManager[957]: <info> (wlan0): supplicant interface state: scanning -> authenticating                  
Feb  1 11:54:28 x220 NetworkManager[957]: <info> (wlan0): supplicant interface state: authenticating -> associating                                    
Feb  1 11:54:28 x220 NetworkManager[957]: NetworkManager[957]: <info> (wlan0): supplicant interface state: authenticating -> associating               
Feb  1 11:54:28 x220 NetworkManager[957]: <info> (wlan0): supplicant interface state: associating -> 4-way handshake                                   
Feb  1 11:54:28 x220 NetworkManager[957]: NetworkManager[957]: <info> (wlan0): supplicant interface state: associating -> 4-way handshake              
Feb  1 11:54:28 x220 NetworkManager[957]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed                                     
Feb  1 11:54:28 x220 NetworkManager[957]: NetworkManager[957]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed                
Feb  1 11:57:00 x220 kernel: [ 8287.729958] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0                             
Feb  1 11:57:12 x220 kernel: [ 8300.012046] iwlwifi 0000:03:00.0: Queue 12 stuck for 10000 ms.                                                         
Feb  1 11:57:12 x220 kernel: [ 8300.012051] iwlwifi 0000:03:00.0: Current SW read_ptr 131 write_ptr 98                                                 
Feb  1 11:57:12 x220 kernel: [ 8300.012085] iwlwifi 0000:03:00.0: Current HW read_ptr 131 write_ptr 98                                                 
Feb  1 11:57:12 x220 kernel: [ 8300.012087] iwlwifi 0000:03:00.0: On demand firmware reload                                                            
Feb  1 11:57:12 x220 kernel: [ 8300.012545] ieee80211 phy0: Hardware restart was requested                                                             
Feb  1 11:57:12 x220 kernel: [ 8300.012663] iwlwifi 0000:03:00.0: L1 Disabled; Enabling L0S                                                            
Feb  1 11:57:12 x220 kernel: [ 8300.012800] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0   


I get this messages on 3.2.1 too:
iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:1f:3f:a0:35:7b tid = 0  
But around or two times and not a hundred times as with kernel 3.2.2
Comment 2 Emanuel-Emeric Andrasi 2012-02-01 07:23:17 EST
I can confirm this too on Fedora 16 kernel-3.2.2-1.fc16.x86_64 on a Dell Vostro 1720 with Intel Corporation WiFi Link 5100 (b/g/n). The symptoms and logs are the same. Btw, if it matters in some way, my WiFi connection is a N-band only.
Comment 3 John W. Linville 2012-02-01 10:24:52 EST

*** This bug has been marked as a duplicate of bug 785239 ***

Note You need to log in before you can comment on or make changes to this bug.