Bug 78553 - FAM broken by design?
FAM broken by design?
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: fam (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-25 13:38 EST by Jack Neely
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-25 13:38:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Neely 2002-11-25 13:38:43 EST
Description of Problem:
I think that this is a known problem but I don't see it documented any where so
I will here or at an upstream point if someone will point me in the right direction.

FAM assumes that it can read your home directory (or whatever directory) as a
daemon run by root.  This doesn't work on all filesystems and causes some
interesting problems.  With AFS the user must be authenticated and have the
proper access rights to be able to read in a directory and in all cases this
does not include root.  The root user translates to system:anyuser which is
normally given no access rights to home directories.  I assume that similar
issues would happen with other file systems.

Shouldn't this be a daemon started as the user who's files are to be monitored?

On Red Hat Linux 7.3 this causes desktop icons to simply dissapear when clicked
on among other oddities.  Disabling FAM seems to work around the issue pretty
well but applications (gedit) complain pretty bitterly and I have the feeling
that applications will become more dependant on this in the future.

Version-Release number of selected component (if applicable):
fam-2.6.8-4
fam-2.6.7-6
I guess I should just say all versions.

How Reproducible:
Always.
Comment 1 Alexander Larsson 2002-11-26 03:50:27 EST
Yes. This is another reason why FAM is the suck(tm).

It's not really fixable with the current implementation though. I have long
wanted to do a rewrite of fam that is per-user and sane. I still hope that I may
some day have time to do it.

I'm marking this WONTFIX though, because in the context of fam it's unfixable.

Note You need to log in before you can comment on or make changes to this bug.