Bug 785565 - [ovirt] [webadmin] refresh problem after discover & login to target - content of getDeviceList is not presented
Summary: [ovirt] [webadmin] refresh problem after discover & login to target - content...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.3.4
Assignee: Daniel Erez
QA Contact:
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-29 15:52 UTC by Dafna Ron
Modified: 2016-02-10 16:47 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-08 16:56:42 UTC
oVirt Team: Storage


Attachments (Terms of Use)
log (44.70 KB, application/x-gzip)
2012-01-29 15:52 UTC, Dafna Ron
no flags Details
logs (1.44 MB, application/x-gzip)
2012-01-30 08:56 UTC, Dafna Ron
no flags Details

Description Dafna Ron 2012-01-29 15:52:21 UTC
Created attachment 558177 [details]
log

Description of problem:

trying to create a new domain I logged in to a target and pressed OK in GUI, I could see GetConfigurationValueQuery is running but nothing happened and gui dialogue came back. 
after logging out of the session and connecting again I was able to create the domain


Version-Release number of selected component (if applicable):

ovirt-engine-backend-3.0.0_0001-1.4.fc16.x86_64
ovirt-engine-webadmin-portal-3.0.0_0001-1.4.fc16.x86_64

How reproducible:

could not reproduce - seems to be random

Steps to Reproduce:
1. try to add new iscsi domain
2.
3.
  
Actual results:

login to target (second screen) and press OK -> dialogue kept re-appearing and engine log would show that GetConfigurationValueQuery is sent but nothing happens after that. 
I had to log in and out to be able to create a domain

Expected results:

we should be able to create a domain

Additional info: full engine log


2012-01-29 17:35:56,316 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (pool-5-thread-47) FINISH, DisconnectStorageServerVDSCommand, return: {549ae35c-4081-4ef3-be83-221c1c1b47ac=0}, log id: 524f20eb
2012-01-29 17:35:56,342 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (pool-5-thread-48) FINISH, DisconnectStorageServerVDSCommand, return: {549ae35c-4081-4ef3-be83-221c1c1b47ac=0}, log id: 49e2bb6
2012-01-29 17:35:56,418 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-8) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:35:56,418 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-6) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:35:56,422 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-5) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:35:56,422 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-3) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:35:56,695 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-6) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:35:56,717 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetDeviceListVDSCommand] (http--0.0.0.0-8080-5) START, GetDeviceListVDSCommand(vdsId = e28783be-4a8a-11e1-91a3-001a4a169741, storageType=ISCSI), log id: 3d3aec79
2012-01-29 17:35:58,982 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetDeviceListVDSCommand] (http--0.0.0.0-8080-5) FINISH, GetDeviceListVDSCommand, return: [org.ovirt.engine.core.common.businessentities.LUNs@1e868b52], log id: 3d3aec79
2012-01-29 17:36:08,598 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DiscoverSendTargetsVDSCommand] (http--0.0.0.0-8080-8) START, DiscoverSendTargetsVDSCommand(vdsId = e28783be-4a8a-11e1-91a3-001a4a169741, connection=org.ovirt.engine.core.common.businessentities.storage_server_connections@0), log id: 6e5917ea
2012-01-29 17:36:08,842 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DiscoverSendTargetsVDSCommand] (http--0.0.0.0-8080-8) FINISH, DiscoverSendTargetsVDSCommand, return: [org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0, org.ovirt.engine.core.common.businessentities.storage_server_connections@0], log id: 6e5917ea
2012-01-29 17:36:28,174 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-4) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:36:28,178 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-2) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:36:28,183 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-6) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:36:28,188 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-3) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:36:28,399 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-4) calling GetConfigurationValueQuery with null version, using default general for version
2012-01-29 17:36:28,419 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetDeviceListVDSCommand] (http--0.0.0.0-8080-2) START, GetDeviceListVDSCommand(vdsId = e28783be-4a8a-11e1-91a3-001a4a169741, storageType=ISCSI), log id: 778873b
2012-01-29 17:36:30,840 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetDeviceListVDSCommand] (http--0.0.0.0-8080-2) FINISH, GetDeviceListVDSCommand, return: [org.ovirt.engine.core.common.businessentities.LUNs@1e868b52], log id: 778873b

Comment 1 Moran Goldboim 2012-01-29 21:41:05 UTC
Dafna, your DiscoverSendTargetsVDSCommand seems wrong - can you attach vdsm log and version please.
do you happen to have a clear repo steps on this (100%)?

Comment 2 Dafna Ron 2012-01-30 08:11:23 UTC
I did not attach vdsm logs because when running the command nothing happened, but I can find the logs from yesterday at that time. 
This cannot be reproduced - it looks random.

Comment 3 Dafna Ron 2012-01-30 08:56:02 UTC
Created attachment 558289 [details]
logs

vdsm logs are attached

Comment 4 Haim 2012-01-30 10:40:10 UTC
(In reply to comment #1)
> Dafna, your DiscoverSendTargetsVDSCommand seems wrong - can you attach vdsm log
> and version please.
> do you happen to have a clear repo steps on this (100%)?

moved component to web-admin. 
it appears to be a refresh issue after sending the commands, manage to correlate the logs on the specific vds (blond-vdsf) and caught the getDeviceList(), which returned fully on that time.


Note You need to log in before you can comment on or make changes to this bug.