Bug 785581 - [abrt] system-config-printer-1.3.8-1.fc16: newprinter.py:1531:getNetworkPrinterMakeModel:TypeError: coercing to Unicode: need string or buffer, list found
[abrt] system-config-printer-1.3.8-1.fc16: newprinter.py:1531:getNetworkPrint...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:d87ef3bc62fe137077180359683...
:
: 785582 785584 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-29 13:12 EST by Pascal94
Modified: 2012-03-14 22:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: system-config-printer-1.3.8-4.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 22:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pascal94 2012-01-29 13:12:01 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
comment:        I was trying to install and configure my Brother MFC-465CN printer, using Brother drivers and tutorial
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.2.2-1.fc16.x86_64
reason:         newprinter.py:1531:getNetworkPrinterMakeModel:TypeError: coercing to Unicode: need string or buffer, list found
time:           dim. 29 janv. 2012 19:10:51 CET
uid:            1000
username:       pascal

backtrace:
:newprinter.py:1531:getNetworkPrinterMakeModel:TypeError: coercing to Unicode: need string or buffer, list found
:
:Traceback (most recent call last):
:  File "/usr/share/system-config-printer/newprinter.py", line 2403, in on_tvNPDevices_cursor_changed
:    device=device)
:  File "/usr/share/system-config-printer/newprinter.py", line 1531, in getNetworkPrinterMakeModel
:    debugprint (host + ": " + args)
:TypeError: coercing to Unicode: need string or buffer, list found
:
:Local variables in innermost frame:
:device: <cupshelpers.Device "socket://192.168.1.3">
:host: dbus.String(u'192.168.1.3')
:args: ['/usr/lib/cups/backend/snmp', dbus.String(u'192.168.1.3')]
:uri: None
:self: <NewPrinterGUI object at 0x2faa3c0 (newprinter+NewPrinterGUI at 0x304c8e0)>

smolt_data:
:
:
:Général
:=================================
:UUID: 756d85a3-7da0-485b-a3b7-e8556a280c20
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: x86_64
:BogoMIPS: 6221.86
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Quad  CPU   Q9550  @ 2.83GHz
:Stepping du processeur: 7
:Famille de processeur: 6
:Modèle du processeur: 23
:Nombre de processeurs: 4
:Vitesse du processeur: 2830
:Mémoire du système: 3946
:Swap du système: 5119
:Fabricant: System manufacturer
:Système: System Product Name System Version
:Type d'ordinateur: Desktop
:Noyau: 3.2.2-1.fc16.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:10168:4163:33145) pci, None, PCI/ISA, P5KPL-VM Motherboard
:(32902:10690:4163:33456) pci, i915, VIDEO, P5KPL-VM Motherboard
:(32902:10176:4163:33145) pci, ata_piix, STORAGE, P5KPL-VM Motherboard
:(32902:10192:4163:33145) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4163:33145) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4163:33719) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10207:4163:33145) pci, ata_piix, STORAGE, P5KPL-VM Motherboard
:(32902:10202:4163:33145) pci, None, SERIAL, P5KPL-VM Motherboard
:(32902:9294:4163:33145) pci, None, PCI/PCI, 82801 PCI Bridge
:(6505:4134:4163:33564) pci, ATL1E, ETHERNET, AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
:(32902:10185:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10184:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10688:4163:33456) pci, agpgart-intel, HOST/PCI, P5KPL-VM Motherboard
:(32902:10186:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10187:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10188:4163:33145) pci, ehci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 5235435 4232131 4179722 1310720 1203267 1203267
:/dev/sda3 /home ext4 4096 4096 71507561 60042446 56463003 17899520 17878017 17878017
:
Comment 1 Jiri Popelka 2012-01-30 05:43:59 EST
*** Bug 785582 has been marked as a duplicate of this bug. ***
Comment 2 Jiri Popelka 2012-01-30 05:44:09 EST
*** Bug 785584 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Popelka 2012-01-30 05:47:08 EST
Problem is in upstream commit
http://git.fedorahosted.org/git/?p=system-config-printer.git;a=commitdiff;h=c3dd31b2e9845e50607c765bbf65465a17ad3877

Fix would be
- debugprint (host + ": " + args)
+ debugprint (host + ": " + repr(args))
Comment 4 Fedora Update System 2012-01-30 10:46:17 EST
system-config-printer-1.3.8-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-0923/system-config-printer-1.3.8-2.fc16
Comment 5 Fedora Update System 2012-01-30 10:52:00 EST
system-config-printer-1.3.8-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/FEDORA-2012-0943/system-config-printer-1.3.8-2.fc15
Comment 6 Fedora Update System 2012-01-30 15:57:25 EST
Package system-config-printer-1.3.8-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.8-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0943/system-config-printer-1.3.8-2.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-02-27 11:05:07 EST
system-config-printer-1.3.8-4.fc16, python-cups-1.9.60-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-2401/system-config-printer-1.3.8-4.fc16,python-cups-1.9.60-2.fc16
Comment 8 Fedora Update System 2012-02-27 11:14:43 EST
system-config-printer-1.3.8-4.fc15, python-cups-1.9.60-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/FEDORA-2012-2396/system-config-printer-1.3.8-4.fc15,python-cups-1.9.60-2.fc15
Comment 9 Fedora Update System 2012-03-14 22:20:58 EDT
system-config-printer-1.3.8-4.fc16, python-cups-1.9.60-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-03-14 22:29:00 EDT
system-config-printer-1.3.8-4.fc15, python-cups-1.9.60-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.