This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 785594 - curl backend is broken
curl backend is broken
Status: CLOSED DUPLICATE of bug 971790
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-29 15:48 EST by Fabian Deutsch
Modified: 2013-06-07 14:04 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-01-29 15:48:25 EST
Qemu got support for it's curl backend, but sadly it seems to be broken. UPstream can't confirm this, so it might be related to the fedora specific patches.

Can be tested using
$ qemu -cdrom http://mirror.de.leaseweb.net/fedora/linux//releases/16/Fedora/x86_64/os/images/boot.iso
Comment 1 Fedora Admin XMLRPC Client 2012-03-15 13:58:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Cole Robinson 2012-07-10 09:25:49 EDT
Rawhide bugs tend to linger, so moving to F17.
Comment 3 Cole Robinson 2013-05-23 16:49:11 EDT
Hmm. Rich, I know you've followed the upstream thread about this, and I saw you mention something about Fedora's curl being 'broken'. Can you elaborate on that? Will the upstream patch series fix things even with Fedora's curl ?
Comment 4 Richard W.M. Jones 2013-05-24 03:50:00 EDT
(In reply to Cole Robinson from comment #3)
> Hmm. Rich, I know you've followed the upstream thread about this, and I saw
> you mention something about Fedora's curl being 'broken'. Can you elaborate
> on that? Will the upstream patch series fix things even with Fedora's curl ?

Fedora's curl simply doesn't work.  Upstream curl from git
works fine.

Try this test on Fedora 19 w/ qemu >= 1.4 and libguestfs 1.22.
You will need a remote disk image of some sort available over HTTP.

With Fedora curl:

$ export LIBGUESTFS_BACKEND=direct
$ guestfish -a http://192.168.0.249/scratch/winxp.img -i -v
[it just hangs when running qemu using 100% CPU]

With upstream curl compiled from git:

$ export LD_LIBRARY_PATH=~/d/curl/lib/.libs
$ export LIBGUESTFS_BACKEND=direct
$ guestfish -a http://192.168.0.249/scratch/winxp.img -i -v
[...]

Welcome to guestfish, the guest filesystem shell for
editing virtual machine filesystems and disk images.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

Operating system: Microsoft Windows XP
/dev/sda1 mounted on /

><fs> 

I don't know why this is.  We seem to patch curl heavily
in Fedora.
Comment 5 Richard W.M. Jones 2013-05-24 03:55:47 EDT
(In reply to Cole Robinson from comment #3)
> Will the upstream patch series fix things even with Fedora's curl ?

No.
Comment 6 Cole Robinson 2013-06-07 14:04:13 EDT

*** This bug has been marked as a duplicate of bug 971790 ***

Note You need to log in before you can comment on or make changes to this bug.