Bug 78565 - evo 1.2 "override namespace" broken
evo 1.2 "override namespace" broken
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-25 16:26 EST by Rex Dieter
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-29 03:31:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2002-11-25 16:26:02 EST
evolution-1.2-3 from rawhide exhibits the following strange IMAP behavior: 
previous version(s) of evolution (1.0.x_ I had an IMAP namespace of Mail/ (a 
Mail/ folder in my home directory).  In evolution 1.2, no folders in Mail/ 
appear, even though I have (previously) subscribed to them...   
  
If I uncheck "override namespace" then a folder named Mail/ appears in my IMAP 
list of folders, and it does contain all my subscribed mailboxes.  It seems 
that there is a problem with the "Override namespace" option.  
 
See also the ximian bugzilla report at 
http://bugzilla.ximian.com/show_bug.cgi?id=33879
Comment 1 Michael Lee Yohe 2002-11-25 16:50:38 EST
I filed Bug 78252 describing this behavior.  katzj@redhat said that this was an
intentional change and closed the bug to WONTFIX, which I think is strange since
the behavior is indeed BROKEN by any definition.
Comment 2 Jeremy Katz 2002-12-29 03:31:43 EST
The nesting as Michael describes is intentional.  Some of the namespace has
changed in 1.2.1 after feedback on the evolution lists which should handle what
you're seeing I believe
Comment 3 Rex Dieter 2002-12-30 13:43:15 EST
I hope you're right about evo 1.2.1, because as it is, evo-1.2's imap/namespace 
behavior is different (imo, broken) than *every* other imap client I've used 
including ms outlook, ms outlook express, netscape communicator, mozilla mail, 
pine...
Comment 4 Michael Lee Yohe 2002-12-31 11:06:01 EST
Has anyone tried out the new release?  I've been leary on taking the step
forward since 1.0.8 acts funny with every downgrade (done two so far).  I've
checked the Ximian bugzilla and there has been no apparent progress on the bug.
Comment 5 Warren Togami 2002-12-31 16:56:24 EST
Evolution 1.2.1 namespace seems to work properly for me.  I use IMAP with
uw-imapd, all of my mail folders are subscribed within ~/mail/.

You could easily backup your home directory and try an upgrade.  If things go
horribly wrong you can revert easily.
Comment 6 Rex Dieter 2003-01-01 01:36:44 EST
After upgrading to evo 1.2.1 (using rawhide's evo-1.2.1-2), I see no change in  behavior.  Any setting/use of "override namespace" results in *all* my  subscribed folders disappearing.  Ack.  The ximian bug report has had no positive activity, other than others reporting they see similar brokeness.  This certainly is not fixed. 
Comment 7 Rex Dieter 2003-01-20 18:19:03 EST
Warren, you say ~/mail is working for you.  What to you enter in the override 
namespace option?  mail/?  ~/mail?  I'm trying to use ~/Mail, and I've not had 
any success using any of: Mail, Mail/, ~/Mail, ~/Mail/.
Comment 8 Michael Lee Yohe 2003-01-21 09:08:03 EST
Ximian's Bug, 33879, appears to be stopped in the water due to a preference set
forth by the maintainer.  Since the one person who is in charge of the component
refuses to fix the problem because of a personal preference (disagreeing that
the behavior which differs from all major IMAP clients is incorrect), there does
not seem to be a solution to be made available any time soon.

Is there not a patch that Red Hat can provide to change this odd, and unwanted
behavior before it gets shoved into the lap of the 8.1 users who cannot use
1.0.8 instead?

Note You need to log in before you can comment on or make changes to this bug.