Bug 7857 - Message sorting is faulty
Summary: Message sorting is faulty
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine   
(Show other bugs)
Version: 4.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-17 00:03 UTC by Riley H Williams
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-19 20:48:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Riley H Williams 1999-12-17 00:03:02 UTC
Pine 4.10 has a message sorting function on the index screen, accessed with
the '$' command. However, there is a problem with the 'F' (From) suboption
in that it tends to intermingle different senders together.

Looking at the "From:" lines in the messages in question, I would suspect
that it is actually sorting by the sender's username (the part of the email
address prior to the '@' character), and doesn't have any means of
separating different people with the same username.

As an example of this, take messages from the following users:

      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Modra <alan@SPRI.Levels.UniSA.Edu.Au>
      Alan Cox <alan@redhat.com>

I currently have a pine session running with the Linux-Kernel emails sorted
by "From", and those three names occur intermingled as follows:

      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Modra <alan@SPRI.Levels.UniSA.Edu.Au>
      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Cox <alan@redhat.com>
      Alan Cox <alan@redhat.com>
      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Cox <alan@lxorguk.ukuu.org.uk>
      Alan Modra <alan@SPRI.Levels.UniSA.Edu.Au>

That's just choosing a small section thereof - I have nearly 100 emails
from Alan Cox in total. However, the only thing they all have in common is
that the sender's username is "alan" as stated above.

Can I suggest that this be changed to use the full email address when
sorting, rather than the current broken behaviour?

Also, can somebody with the ability to do so please forward this to the
pine development team for comments, as I can't find any means for me to
contact them !!!

Comment 1 Trond Eivind Glomsrxd 2000-04-07 15:26:59 UTC
It's not a bug, it's pine's default behaviour. I agree with your desired
behaviour, but I don't think changing it in Red Hat only is a good idea.

Send your suggestion to the pine team at  pine@cac.washington.edu.

Comment 2 Riley H Williams 2000-04-19 12:19:59 UTC
I'd really love to send it to the Pine development team, but the said email
address appears not to exist - at least, everything I've sent there has bounced
with "addressee unknown" error reports...

Does anybody know what the correct email address is?

Comment 3 Trond Eivind Glomsrxd 2000-04-19 20:48:59 UTC
I've mailed it to the pine mailing list.


Note You need to log in before you can comment on or make changes to this bug.